summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini31
1 files changed, 6 insertions, 25 deletions
diff --git a/tox.ini b/tox.ini
index 40180bc..d9c069a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,19 +3,13 @@ envlist =
# Jython support pending 2.7 support, due 2012-07-15 or so. See:
# http://fwierzbicki.blogspot.com/2012/03/adconion-to-fund-jython-27.html
# py27,pypy,jython,py33,coverage,docs
- py27,py27-pure,pypy,py33,py33-pure,py34,py35,coverage,docs
+ py27,py27-pure,pypy,py33,py33-pure,py34,py35,py36,coverage,docs
[testenv]
deps =
- zope.interface
- zope.testing
- zope.configuration
- zope.component
- zope.location
- zope.proxy
- zope.testrunner
+ .[test]
commands =
- python setup.py -q test -q
+ zope-testrunner --test-path=src --auto-progress --auto-color []
[testenv:py27-pure]
basepython =
@@ -43,28 +37,15 @@ commands =
pip install -e .
nosetests --with-xunit --with-xcoverage
deps =
- zope.interface
- zope.testing
- zope.configuration
- zope.component
- zope.location
- zope.proxy
- nose
+ .[testing]
coverage
nosexcover
[testenv:docs]
basepython =
- python3.3
+ python3.4
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
sphinx-build -b doctest -d docs/_build/doctrees docs docs/_build/doctest
deps =
- zope.interface
- zope.testing
- zope.configuration
- zope.component
- zope.location
- zope.proxy
- Sphinx
- repoze.sphinx.autointerface
+ .[docs,test]