summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2017-04-24 06:54:36 -0500
committerJason Madden <jamadden@gmail.com>2017-04-24 08:00:59 -0500
commit9aaf59b541bc3e0616f9f9f95b6345d1a4400e68 (patch)
treea73601e4bf67de1d67fc67eb43065691c8648130 /tox.ini
parent6292afe78a5eee46405d982405fcc63603478504 (diff)
downloadzope-security-9aaf59b541bc3e0616f9f9f95b6345d1a4400e68.tar.gz
Fix iteration of BTrees.items() in pure-python; and 3.6 support
Also fix ``list(proxy_btree.items())`` (or a list comprehension of the same) in Python 3, which wants the ``__len__`` for a hint. This is a central place to make sure these all behave consistently. Fixes #20 Also drop pypy3 As a 3.2 implementation, it's not supported by pip anymore. There is a much more recent version, 3.5-beta, but it's not on Travis yet. The 3.3-alpha which is on Travis is a dead end.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini31
1 files changed, 6 insertions, 25 deletions
diff --git a/tox.ini b/tox.ini
index 40180bc..d9c069a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,19 +3,13 @@ envlist =
# Jython support pending 2.7 support, due 2012-07-15 or so. See:
# http://fwierzbicki.blogspot.com/2012/03/adconion-to-fund-jython-27.html
# py27,pypy,jython,py33,coverage,docs
- py27,py27-pure,pypy,py33,py33-pure,py34,py35,coverage,docs
+ py27,py27-pure,pypy,py33,py33-pure,py34,py35,py36,coverage,docs
[testenv]
deps =
- zope.interface
- zope.testing
- zope.configuration
- zope.component
- zope.location
- zope.proxy
- zope.testrunner
+ .[test]
commands =
- python setup.py -q test -q
+ zope-testrunner --test-path=src --auto-progress --auto-color []
[testenv:py27-pure]
basepython =
@@ -43,28 +37,15 @@ commands =
pip install -e .
nosetests --with-xunit --with-xcoverage
deps =
- zope.interface
- zope.testing
- zope.configuration
- zope.component
- zope.location
- zope.proxy
- nose
+ .[testing]
coverage
nosexcover
[testenv:docs]
basepython =
- python3.3
+ python3.4
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
sphinx-build -b doctest -d docs/_build/doctrees docs docs/_build/doctest
deps =
- zope.interface
- zope.testing
- zope.configuration
- zope.component
- zope.location
- zope.proxy
- Sphinx
- repoze.sphinx.autointerface
+ .[docs,test]