summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2019-04-06 07:50:50 +0200
committerGitHub <noreply@github.com>2019-04-06 07:50:50 +0200
commitb2babb1c0fbfec301f0cab8334d71697622b1138 (patch)
tree9b8606fd38f62c436472c50e47f31b5642211822 /setup.py
parentfcc4a7f304c31cdb103a18ff02df8fc4d90f2b73 (diff)
downloadzope-security-b2babb1c0fbfec301f0cab8334d71697622b1138.tar.gz
Update to current Python versions. (#61)
Additionally we have to pin an older `Sphinx` version to keep supporting Python 2.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 945d38b..9f6ccae 100644
--- a/setup.py
+++ b/setup.py
@@ -132,7 +132,7 @@ TESTS_REQUIRE = [
setup(name='zope.security',
- version='4.3.2.dev0',
+ version='5.0.dev0',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Zope Security Framework',
@@ -155,6 +155,7 @@ setup(name='zope.security',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
@@ -172,6 +173,7 @@ setup(name='zope.security',
'build_ext': optional_build_ext,
},
features=features,
+ python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*',
install_requires=[
'setuptools',
'zope.component',
@@ -195,7 +197,8 @@ setup(name='zope.security',
],
'test': TESTS_REQUIRE,
'docs': [
- 'Sphinx',
+ 'Sphinx < 2; python_version < "3"',
+ 'Sphinx >= 2; python_version >= "3"',
'repoze.sphinx.autointerface',
],
},