summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2019-04-06 07:50:50 +0200
committerGitHub <noreply@github.com>2019-04-06 07:50:50 +0200
commitb2babb1c0fbfec301f0cab8334d71697622b1138 (patch)
tree9b8606fd38f62c436472c50e47f31b5642211822
parentfcc4a7f304c31cdb103a18ff02df8fc4d90f2b73 (diff)
downloadzope-security-b2babb1c0fbfec301f0cab8334d71697622b1138.tar.gz
Update to current Python versions. (#61)
Additionally we have to pin an older `Sphinx` version to keep supporting Python 2.
-rw-r--r--.travis.yml14
-rw-r--r--CHANGES.rst8
-rw-r--r--appveyor.yml4
-rw-r--r--setup.py7
-rw-r--r--tox.ini15
5 files changed, 29 insertions, 19 deletions
diff --git a/.travis.yml b/.travis.yml
index 75aa4db..1dcbbec 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,22 +1,22 @@
language: python
-sudo: false
+dist: xenial
matrix:
include:
- python: 2.7
- - python: 3.4
- python: 3.5
- python: 3.6
- python: 3.7
- dist: xenial
- sudo: true
- - python: pypy
- - python: pypy3
+ - python: 3.8-dev
+ - python: pypy2.7-6.0
+ - python: pypy3.5-6.0
- python: 2.7
env:
- PURE_PYTHON=1
- ZOPE_WATCH_CHECKERS=1
- - python: 3.4
+ - python: 3.7
env: ZOPE_WATCH_CHECKERS=1
+ - python: 3.7
+ env: PURE_PYTHON=1
install:
- pip install -U pip setuptools
- pip install -U coveralls coverage
diff --git a/CHANGES.rst b/CHANGES.rst
index 1f2292c..a4a20d7 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,10 +2,12 @@
Changes
=========
-4.3.2 (unreleased)
-==================
+5.0 (unreleased)
+================
+
+- Drop support for Python 3.4.
-- Nothing changed yet.
+- Add support for Python 3.8a3.
4.3.1 (2019-01-03)
diff --git a/appveyor.yml b/appveyor.yml
index ec786c7..2f86bda 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -7,8 +7,6 @@ environment:
matrix:
- python: 27
- python: 27-x64
- - python: 34
- - python: 34-x64
- python: 35
- python: 35-x64
- python: 36
@@ -16,7 +14,7 @@ environment:
- python: 37
- python: 37-x64
- { python: 27, PURE_PYTHON: 1 }
- - { python: 35, PURE_PYTHON: 1 }
+ - { python: 37, PURE_PYTHON: 1 }
install:
- "SET PATH=C:\\Python%PYTHON%;c:\\Python%PYTHON%\\scripts;%PATH%"
diff --git a/setup.py b/setup.py
index 945d38b..9f6ccae 100644
--- a/setup.py
+++ b/setup.py
@@ -132,7 +132,7 @@ TESTS_REQUIRE = [
setup(name='zope.security',
- version='4.3.2.dev0',
+ version='5.0.dev0',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Zope Security Framework',
@@ -155,6 +155,7 @@ setup(name='zope.security',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
@@ -172,6 +173,7 @@ setup(name='zope.security',
'build_ext': optional_build_ext,
},
features=features,
+ python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*',
install_requires=[
'setuptools',
'zope.component',
@@ -195,7 +197,8 @@ setup(name='zope.security',
],
'test': TESTS_REQUIRE,
'docs': [
- 'Sphinx',
+ 'Sphinx < 2; python_version < "3"',
+ 'Sphinx >= 2; python_version >= "3"',
'repoze.sphinx.autointerface',
],
},
diff --git a/tox.ini b/tox.ini
index d41b7a3..8c8d88e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,7 +3,7 @@ envlist =
# Jython support pending 2.7 support, due 2012-07-15 or so. See:
# http://fwierzbicki.blogspot.com/2012/03/adconion-to-fund-jython-27.html
# py27,pypy,jython,py33,coverage,docs
- py27,py27-watch,pypy,pypy3,py34-watch,py34,py35,py36,py37,coverage,docs
+ py27,py27-watch,pypy,pypy3,py35,py36,py37-watch,py37-pure,py37,py38,coverage,docs
[testenv]
commands =
@@ -20,13 +20,20 @@ setenv =
ZOPE_WATCH_CHECKERS = 1
PIP_CACHE_DIR = {envdir}/.cache
-[testenv:py34-watch]
+[testenv:py37-watch]
basepython =
- python3.4
+ python3.7
setenv =
ZOPE_WATCH_CHECKERS = 1
PIP_CACHE_DIR = {envdir}/.cache
+[testenv:py37-pure]
+basepython =
+ python3.7
+setenv =
+ PURE_PYTHON = 1
+ PIP_CACHE_DIR = {envdir}/.cache
+
[testenv:coverage]
usedevelop = true
basepython =
@@ -41,7 +48,7 @@ deps =
[testenv:docs]
basepython =
- python3.4
+ python3.7
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
sphinx-build -b doctest -d docs/_build/doctrees docs docs/_build/doctest