summaryrefslogtreecommitdiff
path: root/appveyor.yml
diff options
context:
space:
mode:
authorMarius Gedminas <marius@gedmin.as>2017-09-21 11:55:08 +0300
committerMarius Gedminas <marius@gedmin.as>2017-09-21 11:55:08 +0300
commitaf192bcf603891d63e7bab821f98a6e42fbeea24 (patch)
tree2e06783d419a71a0819fd5299f3b755258259cfb /appveyor.yml
parent8067ed3c4920b3708e5e76717aed4d4998e5ecd5 (diff)
downloadzope-security-af192bcf603891d63e7bab821f98a6e42fbeea24.tar.gz
Build and upload Windows wheels in Appveyor
Fixes #46.
Diffstat (limited to 'appveyor.yml')
-rw-r--r--appveyor.yml33
1 files changed, 24 insertions, 9 deletions
diff --git a/appveyor.yml b/appveyor.yml
index bfa97eb..66c2683 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -1,14 +1,18 @@
environment:
+ global:
+ TWINE_USERNAME: zope.wheelbuilder
+ TWINE_PASSWORD:
+ secure: UcdTh6W78cRLVGfKRFoa5A==
matrix:
- - python : 27
- - python : 27-x64
- - python : 34
- - python : 34-x64
- - python : 35
- - python : 35-x64
- - python : 36
- - python : 36-x64
+ - python: 27
+ - python: 27-x64
+ - python: 34
+ - python: 34-x64
+ - python: 35
+ - python: 35-x64
+ - python: 36
+ - python: 36-x64
- { python: 27, PURE_PYTHON: 1 }
- { python: 35, PURE_PYTHON: 1 }
@@ -25,10 +29,21 @@ install:
- pip install -U zope.testrunner
- pip install -U .[test]
-build: false
+build_script:
+ - pip install wheel
+ - python -W ignore setup.py -q bdist_wheel
test_script:
- python -m zope.testrunner --test-path=src
on_success:
- echo Build succesful!
+
+artifacts:
+ - path: 'dist\*.whl'
+ name: wheel
+
+deploy_script:
+ - ps: if ($env:APPVEYOR_REPO_TAG -eq $TRUE -and $env:PURE_PYTHON -ne 1) { pip install twine; twine upload dist/* }
+
+deploy: on