summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--appveyor.yml33
1 files changed, 24 insertions, 9 deletions
diff --git a/appveyor.yml b/appveyor.yml
index bfa97eb..66c2683 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -1,14 +1,18 @@
environment:
+ global:
+ TWINE_USERNAME: zope.wheelbuilder
+ TWINE_PASSWORD:
+ secure: UcdTh6W78cRLVGfKRFoa5A==
matrix:
- - python : 27
- - python : 27-x64
- - python : 34
- - python : 34-x64
- - python : 35
- - python : 35-x64
- - python : 36
- - python : 36-x64
+ - python: 27
+ - python: 27-x64
+ - python: 34
+ - python: 34-x64
+ - python: 35
+ - python: 35-x64
+ - python: 36
+ - python: 36-x64
- { python: 27, PURE_PYTHON: 1 }
- { python: 35, PURE_PYTHON: 1 }
@@ -25,10 +29,21 @@ install:
- pip install -U zope.testrunner
- pip install -U .[test]
-build: false
+build_script:
+ - pip install wheel
+ - python -W ignore setup.py -q bdist_wheel
test_script:
- python -m zope.testrunner --test-path=src
on_success:
- echo Build succesful!
+
+artifacts:
+ - path: 'dist\*.whl'
+ name: wheel
+
+deploy_script:
+ - ps: if ($env:APPVEYOR_REPO_TAG -eq $TRUE -and $env:PURE_PYTHON -ne 1) { pip install twine; twine upload dist/* }
+
+deploy: on