summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMichael Howitz <icemac@gmx.net>2023-02-07 11:36:18 +0100
committerGitHub <noreply@github.com>2023-02-07 11:36:18 +0100
commitf7b94db50380db535bad8bd7783f72470eda257c (patch)
tree4153ef2c4a2ff4ac709338d55baa51a967ebd4c0 /setup.py
parent8f8ed8f7b603792b48401a64b51e900e86b88a82 (diff)
downloadzope-pagetemplate-f7b94db50380db535bad8bd7783f72470eda257c.tar.gz
Add support for ``zope.untrustedpython`` on Python 3. (#29)
With it, Python expressions are now protected by RestrictedPython.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 4b2fb6d..fd2ddba 100644
--- a/setup.py
+++ b/setup.py
@@ -34,6 +34,7 @@ TESTS_REQUIRE = [
'zope.security',
'zope.testing',
'zope.testrunner',
+ 'zope.untrustedpython >= 5.0.dev0',
]
@@ -75,6 +76,7 @@ setup(name='zope.pagetemplate',
extras_require={
'test': TESTS_REQUIRE,
'untrusted': [
+ 'zope.untrustedpython >= 5.0.dev0',
],
'docs': [
'Sphinx',