summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Vagelpohl <jens@plyp.com>2022-11-03 13:50:45 +0100
committerJens Vagelpohl <jens@plyp.com>2022-11-03 13:50:45 +0100
commitd672d91c62b5c36fa2c1c9ce13dc7fe2ad1efe2f (patch)
treee004cf58d87f6784eae3cf787ec838b78a061ccc
parent391db8a4c47972df72b75a81801fa6a5ca746ddc (diff)
downloadzope-interface-d672d91c62b5c36fa2c1c9ce13dc7fe2ad1efe2f.tar.gz
- prepare release 5.5.15.5.1
-rw-r--r--.github/workflows/tests.yml11
-rwxr-xr-x.manylinux-install.sh11
-rw-r--r--.meta.toml4
-rw-r--r--CHANGES.rst2
-rw-r--r--appveyor.yml2
-rw-r--r--setup.py2
-rw-r--r--tox.ini2
7 files changed, 7 insertions, 27 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index 6af3349..5d026bd 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -154,16 +154,6 @@ jobs:
pip install -U pip
pip install -U setuptools wheel twine cffi
- - name: Build zope.interface (3.11)
- if: ${{ startsWith(matrix.python-version, '3.11') }}
- run: |
- # Next, build the wheel *in place*. This helps ccache, and also lets us cache the configure
- # output (pip install uses a random temporary directory, making this difficult).
- python setup.py build_ext -i
- python setup.py bdist_wheel
- # Also install it, so that we get dependencies in the (pip) cache.
- pip install -U 'faulthandler; python_version == "2.7" and platform_python_implementation == "CPython"'
- pip install --pre .[test]
- name: Build zope.interface (Python 3.10 on MacOS)
if: >
startsWith(runner.os, 'Mac')
@@ -210,7 +200,6 @@ jobs:
&& startsWith(github.ref, 'refs/tags')
&& startsWith(runner.os, 'Mac')
&& !startsWith(matrix.python-version, 'pypy')
- && !startsWith(matrix.python-version, '3.11')
env:
TWINE_PASSWORD: ${{ secrets.TWINE_PASSWORD }}
run: |
diff --git a/.manylinux-install.sh b/.manylinux-install.sh
index 6cb729c..3eb634e 100755
--- a/.manylinux-install.sh
+++ b/.manylinux-install.sh
@@ -30,12 +30,12 @@ tox_env_map() {
case $1 in
*"cp27"*) echo 'py27';;
*"cp35"*) echo 'py35';;
- *"cp311"*) echo 'py311';;
*"cp36"*) echo 'py36';;
*"cp37"*) echo 'py37';;
*"cp38"*) echo 'py38';;
*"cp39"*) echo 'py39';;
*"cp310"*) echo 'py310';;
+ *"cp311"*) echo 'py311';;
*) echo 'py';;
esac
}
@@ -51,13 +51,8 @@ for PYBIN in /opt/python/*/bin; do
[[ "${PYBIN}" == *"cp38"* ]] || \
[[ "${PYBIN}" == *"cp39"* ]] || \
[[ "${PYBIN}" == *"cp310"* ]] ; then
- if [[ "${PYBIN}" == *"cp311"* ]] ; then
- "${PYBIN}/pip" install --pre -e /io/
- "${PYBIN}/pip" wheel /io/ --pre -w wheelhouse/
- else
- "${PYBIN}/pip" install -e /io/
- "${PYBIN}/pip" wheel /io/ -w wheelhouse/
- fi
+ "${PYBIN}/pip" install -e /io/
+ "${PYBIN}/pip" wheel /io/ -w wheelhouse/
if [ `uname -m` == 'aarch64' ]; then
cd /io/
${PYBIN}/pip install tox
diff --git a/.meta.toml b/.meta.toml
index d525536..0967d72 100644
--- a/.meta.toml
+++ b/.meta.toml
@@ -2,7 +2,7 @@
# https://github.com/zopefoundation/meta/tree/master/config/c-code
[meta]
template = "c-code"
-commit-id = "70229255d495a945324228b50ee735cc75e01430"
+commit-id = "b4dd6f9ffd3d6a2cde7dc70512c62d4c7ed22cd6"
[python]
with-appveyor = true
@@ -10,7 +10,7 @@ with-pypy = true
with-legacy-python = true
with-sphinx-doctests = true
with-windows = false
-with-future-python = true
+with-future-python = false
with-docs = true
[tox]
diff --git a/CHANGES.rst b/CHANGES.rst
index 6174435..385484e 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,7 +2,7 @@
Changes
=========
-5.5.1 (unreleased)
+5.5.1 (2022-11-03)
==================
- Add support for final Python 3.11 release.
diff --git a/appveyor.yml b/appveyor.yml
index c48c690..e765462 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -24,8 +24,6 @@ environment:
- python: 39-x64
- python: 310
- python: 310-x64
- # `multibuild` cannot install non-final versions as they are not on
- # ftp.python.org, so we skip Python 3.11 until its final release:
- python: 311
- python: 311-x64
diff --git a/setup.py b/setup.py
index 93a1423..08a27df 100644
--- a/setup.py
+++ b/setup.py
@@ -100,7 +100,7 @@ long_description = (
)
setup(name='zope.interface',
- version='5.5.1.dev0',
+ version='5.5.1',
url='https://github.com/zopefoundation/zope.interface',
license='ZPL 2.1',
description='Interfaces for Python',
diff --git a/tox.ini b/tox.ini
index 25dd60c..d57b340 100644
--- a/tox.ini
+++ b/tox.ini
@@ -19,9 +19,7 @@ envlist =
[testenv]
usedevelop = true
-pip_pre = py311: true
deps =
- Sphinx
setenv =
pure: PURE_PYTHON=1
!pure-!pypy-!pypy3: PURE_PYTHON=0