summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Vagelpohl <jens@plyp.com>2022-11-02 11:09:27 +0100
committerJens Vagelpohl <jens@plyp.com>2022-11-02 11:09:27 +0100
commit391db8a4c47972df72b75a81801fa6a5ca746ddc (patch)
treef97578701d98825b1bf450e47cead9474754d60a
parentd65b9977fc3f282693441c6828ea1044a79430a1 (diff)
downloadzope-interface-391db8a4c47972df72b75a81801fa6a5ca746ddc.tar.gz
- update to the latest meta/config and declare Python 3.11 support
-rw-r--r--.github/workflows/tests.yml20
-rw-r--r--.meta.toml2
-rw-r--r--CHANGES.rst2
-rw-r--r--appveyor.yml4
-rw-r--r--setup.py1
5 files changed, 15 insertions, 14 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index accbb46..6af3349 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -105,7 +105,7 @@ jobs:
- "3.8"
- "3.9"
- "3.10"
- - "3.11.0-rc.2"
+ - "3.11"
os: [ubuntu-20.04, macos-latest]
exclude:
- os: macos-latest
@@ -131,7 +131,7 @@ jobs:
- name: Get pip cache dir
id: pip-cache
run: |
- echo "::set-output name=dir::$(pip cache dir)"
+ echo "dir=$(pip cache dir)" >>$GITHUB_OUTPUT
- name: pip cache
uses: actions/cache@v2
@@ -154,8 +154,8 @@ jobs:
pip install -U pip
pip install -U setuptools wheel twine cffi
- - name: Build zope.interface (3.11.0-rc.2)
- if: ${{ startsWith(matrix.python-version, '3.11.0-rc.2') }}
+ - name: Build zope.interface (3.11)
+ if: ${{ startsWith(matrix.python-version, '3.11') }}
run: |
# Next, build the wheel *in place*. This helps ccache, and also lets us cache the configure
# output (pip install uses a random temporary directory, making this difficult).
@@ -210,7 +210,7 @@ jobs:
&& startsWith(github.ref, 'refs/tags')
&& startsWith(runner.os, 'Mac')
&& !startsWith(matrix.python-version, 'pypy')
- && !startsWith(matrix.python-version, '3.11.0-rc.2')
+ && !startsWith(matrix.python-version, '3.11')
env:
TWINE_PASSWORD: ${{ secrets.TWINE_PASSWORD }}
run: |
@@ -232,7 +232,7 @@ jobs:
- "3.8"
- "3.9"
- "3.10"
- - "3.11.0-rc.2"
+ - "3.11"
os: [ubuntu-20.04, macos-latest]
exclude:
- os: macos-latest
@@ -258,7 +258,7 @@ jobs:
- name: Get pip cache dir
id: pip-cache
run: |
- echo "::set-output name=dir::$(pip cache dir)"
+ echo "dir=$(pip cache dir)" >>$GITHUB_OUTPUT
- name: pip cache
uses: actions/cache@v2
@@ -335,7 +335,7 @@ jobs:
- name: Get pip cache dir
id: pip-cache
run: |
- echo "::set-output name=dir::$(pip cache dir)"
+ echo "dir=$(pip cache dir)" >>$GITHUB_OUTPUT
- name: pip cache
uses: actions/cache@v2
@@ -386,7 +386,7 @@ jobs:
- name: Get pip cache dir
id: pip-cache
run: |
- echo "::set-output name=dir::$(pip cache dir)"
+ echo "dir=$(pip cache dir)" >>$GITHUB_OUTPUT
- name: pip cache
uses: actions/cache@v2
@@ -439,7 +439,7 @@ jobs:
- name: Get pip cache dir
id: pip-cache
run: |
- echo "::set-output name=dir::$(pip cache dir)"
+ echo "dir=$(pip cache dir)" >>$GITHUB_OUTPUT
- name: pip cache
uses: actions/cache@v2
diff --git a/.meta.toml b/.meta.toml
index 0f43c4d..d525536 100644
--- a/.meta.toml
+++ b/.meta.toml
@@ -2,7 +2,7 @@
# https://github.com/zopefoundation/meta/tree/master/config/c-code
[meta]
template = "c-code"
-commit-id = "b5df3766ff8923477f3d24729b19504f0c401a2e"
+commit-id = "70229255d495a945324228b50ee735cc75e01430"
[python]
with-appveyor = true
diff --git a/CHANGES.rst b/CHANGES.rst
index c17b168..6174435 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,7 +5,7 @@
5.5.1 (unreleased)
==================
-- Nothing changed yet.
+- Add support for final Python 3.11 release.
5.5.0 (2022-10-10)
diff --git a/appveyor.yml b/appveyor.yml
index 4b8bf63..c48c690 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -26,8 +26,8 @@ environment:
- python: 310-x64
# `multibuild` cannot install non-final versions as they are not on
# ftp.python.org, so we skip Python 3.11 until its final release:
- # - python: 311
- # - python: 311-x64
+ - python: 311
+ - python: 311-x64
install:
- "SET PYTHONVERSION=%PYTHON%"
diff --git a/setup.py b/setup.py
index d44fc43..93a1423 100644
--- a/setup.py
+++ b/setup.py
@@ -122,6 +122,7 @@ setup(name='zope.interface',
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Framework :: Zope :: 3",