summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2021-12-09 08:36:26 +0100
committerGitHub <noreply@github.com>2021-12-09 08:36:26 +0100
commit8cf8c020d064ec543bc9fc0cf9410981e2495226 (patch)
treefca3ca4a494b3c15306ad28f8df262756de95a1b
parent8a13762e60726845351d672ee27c093555bf649e (diff)
downloadzope-i18n-8cf8c020d064ec543bc9fc0cf9410981e2495226.tar.gz
Add support for Python 3.10. (#53)
-rw-r--r--.github/workflows/tests.yml7
-rw-r--r--.meta.toml2
-rw-r--r--CHANGES.rst4
-rw-r--r--setup.py3
-rw-r--r--tox.ini9
5 files changed, 12 insertions, 13 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index 9ea114e..d31f648 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -20,17 +20,18 @@ jobs:
- ubuntu
config:
# [Python version, tox env]
- - ["3.8", "lint"]
+ - ["3.9", "lint"]
- ["2.7", "py27"]
- ["3.5", "py35"]
- ["3.6", "py36"]
- ["3.7", "py37"]
- ["3.8", "py38"]
- ["3.9", "py39"]
+ - ["3.10", "py310"]
- ["pypy2", "pypy"]
- ["pypy3", "pypy3"]
- - ["3.8", "docs"]
- - ["3.8", "coverage"]
+ - ["3.9", "docs"]
+ - ["3.9", "coverage"]
runs-on: ${{ matrix.os }}-latest
name: ${{ matrix.config[1] }}
diff --git a/.meta.toml b/.meta.toml
index 53d84cb..492325b 100644
--- a/.meta.toml
+++ b/.meta.toml
@@ -2,7 +2,7 @@
# https://github.com/zopefoundation/meta/tree/master/config/pure-python
[meta]
template = "pure-python"
-commit-id = "7f5b73fe9d2bcbabafaef5f69dd97408a142d42a"
+commit-id = "fba6d957ba447b6fa369d872e803756bd5176391"
[python]
with-windows = false
diff --git a/CHANGES.rst b/CHANGES.rst
index 2ba0f08..c4bf79a 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,7 +2,7 @@
CHANGES
=========
-4.8.1 (unreleased)
+4.9.0 (unreleased)
==================
- Fix date/time format for zh, sv, and es_US.
@@ -12,6 +12,8 @@
module variable in ``config.py`` in a non-breaking way.
See also `Zope issue #994 <https://github.com/zopefoundation/Zope/issues/994>`_
+- Add support for Python 3.10.
+
4.8.0 (2021-09-07)
==================
diff --git a/setup.py b/setup.py
index ee8b410..6bed647 100644
--- a/setup.py
+++ b/setup.py
@@ -62,7 +62,7 @@ TESTS_REQUIRE = COMPILE_REQUIRES + ZCML_REQUIRES + [
setup(
name='zope.i18n',
- version='4.8.1.dev0',
+ version='4.9.0.dev0',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Zope Internationalization Support',
@@ -88,6 +88,7 @@ setup(
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index da82bb1..7cf2afc 100644
--- a/tox.ini
+++ b/tox.ini
@@ -10,6 +10,7 @@ envlist =
py37
py38
py39
+ py310
pypy
pypy3
docs
@@ -18,8 +19,6 @@ envlist =
[testenv]
usedevelop = true
deps =
- # Until repoze.sphinx.autointerface supports Sphinx 4.x we cannot use it:
- Sphinx < 4
commands =
zope-testrunner --test-path=src {posargs:-vc}
!py27-!pypy: sphinx-build -b doctest -d {envdir}/.cache/doctrees docs {envdir}/.cache/doctest
@@ -33,7 +32,7 @@ skip_install = true
deps =
flake8
check-manifest
- check-python-versions
+ check-python-versions >= 0.19.1
wheel
commands =
flake8 src setup.py
@@ -43,8 +42,6 @@ commands =
[testenv:docs]
basepython = python3
skip_install = false
-# Until repoze.sphinx.autointerface supports Sphinx 4.x we cannot use it:
-deps = Sphinx < 4
commands_pre =
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
@@ -57,8 +54,6 @@ allowlist_externals =
deps =
coverage
coverage-python-version
- # Until repoze.sphinx.autointerface supports Sphinx 4.x we cannot use it:
- Sphinx < 4
commands =
mkdir -p {toxinidir}/parts/htmlcov
coverage run -m zope.testrunner --test-path=src {posargs:-vc}