summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini9
1 files changed, 2 insertions, 7 deletions
diff --git a/tox.ini b/tox.ini
index da82bb1..7cf2afc 100644
--- a/tox.ini
+++ b/tox.ini
@@ -10,6 +10,7 @@ envlist =
py37
py38
py39
+ py310
pypy
pypy3
docs
@@ -18,8 +19,6 @@ envlist =
[testenv]
usedevelop = true
deps =
- # Until repoze.sphinx.autointerface supports Sphinx 4.x we cannot use it:
- Sphinx < 4
commands =
zope-testrunner --test-path=src {posargs:-vc}
!py27-!pypy: sphinx-build -b doctest -d {envdir}/.cache/doctrees docs {envdir}/.cache/doctest
@@ -33,7 +32,7 @@ skip_install = true
deps =
flake8
check-manifest
- check-python-versions
+ check-python-versions >= 0.19.1
wheel
commands =
flake8 src setup.py
@@ -43,8 +42,6 @@ commands =
[testenv:docs]
basepython = python3
skip_install = false
-# Until repoze.sphinx.autointerface supports Sphinx 4.x we cannot use it:
-deps = Sphinx < 4
commands_pre =
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
@@ -57,8 +54,6 @@ allowlist_externals =
deps =
coverage
coverage-python-version
- # Until repoze.sphinx.autointerface supports Sphinx 4.x we cannot use it:
- Sphinx < 4
commands =
mkdir -p {toxinidir}/parts/htmlcov
coverage run -m zope.testrunner --test-path=src {posargs:-vc}