summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2020-05-20 08:29:40 +0200
committerGitHub <noreply@github.com>2020-05-20 08:29:40 +0200
commitda6a9366f0bb33eb0d3977e094e2f8b5d70f41cb (patch)
tree733d22d7c64f402733ff66aebb9752f0d829e173 /setup.py
parentffc45c620523947518b4de4f4458c0e06b56bebf (diff)
downloadzope-browser-da6a9366f0bb33eb0d3977e094e2f8b5d70f41cb.tar.gz
Configuring for pure-python (#5)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 12 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 13cab56..49235d3 100644
--- a/setup.py
+++ b/setup.py
@@ -16,10 +16,12 @@ import os
from setuptools import setup, find_packages
+
def read(*rnames):
with open(os.path.join(os.path.dirname(__file__), *rnames)) as f:
return f.read()
+
setup(
name='zope.browser',
version='2.4.dev0',
@@ -42,10 +44,10 @@ setup(
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
@@ -56,7 +58,15 @@ setup(
url='https://zopebrowser.readthedocs.io',
packages=find_packages('src'),
package_dir={'': 'src'},
- namespace_packages=['zope',],
+ namespace_packages=['zope'],
+ python_requires=', '.join([
+ '>=2.7',
+ '!=3.0.*',
+ '!=3.1.*',
+ '!=3.2.*',
+ '!=3.3.*',
+ '!=3.4.*',
+ ]),
install_requires=[
'setuptools',
'zope.interface',