summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.coveragerc11
-rw-r--r--.editorconfig39
-rw-r--r--.gitignore34
-rw-r--r--.meta.cfg7
-rw-r--r--.travis.yml45
-rw-r--r--CHANGES.rst4
-rw-r--r--MANIFEST.in19
-rw-r--r--bootstrap.py210
-rw-r--r--setup.cfg11
-rw-r--r--setup.py14
-rw-r--r--src/zope/__init__.py8
-rw-r--r--src/zope/browser/interfaces.py19
-rw-r--r--src/zope/browser/tests.py6
-rw-r--r--tox.ini64
14 files changed, 195 insertions, 296 deletions
diff --git a/.coveragerc b/.coveragerc
deleted file mode 100644
index 26ef06b..0000000
--- a/.coveragerc
+++ /dev/null
@@ -1,11 +0,0 @@
-[run]
-source = zope.browser
-
-[report]
-precision = 2
-exclude_lines =
- pragma: no cover
- if __name__ == '__main__':
- raise NotImplementedError
- self.fail
- raise AssertionError
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 0000000..f3e46f5
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,39 @@
+# Generated from:
+# https://github.com/zopefoundation/meta/tree/master/config/pure-python
+#
+# EditorConfig Configuration file, for more details see:
+# http://EditorConfig.org
+# EditorConfig is a convention description, that could be interpreted
+# by multiple editors to enforce common coding conventions for specific
+# file types
+
+# top-most EditorConfig file:
+# Will ignore other EditorConfig files in Home directory or upper tree level.
+root = true
+
+
+[*] # For All Files
+# Unix-style newlines with a newline ending every file
+end_of_line = lf
+insert_final_newline = true
+trim_trailing_whitespace = true
+# Set default charset
+charset = utf-8
+# Indent style default
+indent_style = space
+# Max Line Length - a hard line wrap, should be disabled
+max_line_length = off
+
+[*.{py,cfg,ini}]
+# 4 space indentation
+indent_size = 4
+
+[*.{yml,zpt,pt,dtml}]
+# 2 space indentation
+indent_size = 2
+
+[{Makefile,.gitmodules}]
+# Tab indentation (no size specified, but view as 4 spaces)
+indent_style = tab
+indent_size = unset
+tab_width = unset
diff --git a/.gitignore b/.gitignore
index 3ac5f5b..7bd5e56 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,18 +1,24 @@
+# Generated from:
+# https://github.com/zopefoundation/meta/tree/master/config/pure-python
+*.egg-info/
+*.profraw
*.pyc
-*.so
-*.dll
-__pycache__
-src/*.egg-info
-
-.installed.cfg
-.tox
-bin
-build
-develop-eggs
-parts
+*.pyo
.coverage
+.coverage.*
+.installed.cfg
+.mr.developer.cfg
+.tox/
+__pycache__/
+bin/
+build/
coverage.xml
-nosetests.xml
+develop-eggs/
+dist/
+docs/_build
+eggs/
htmlcov/
-
-docs/_build/
+lib/
+lib64
+parts/
+pyvenv.cfg
diff --git a/.meta.cfg b/.meta.cfg
new file mode 100644
index 0000000..c2072a1
--- /dev/null
+++ b/.meta.cfg
@@ -0,0 +1,7 @@
+# Generated from:
+# https://github.com/zopefoundation/meta/tree/master/config/pure-python
+[meta]
+template = pure-python
+commit-id = 4f6e46d28989b99f6dd6ee49829060a6720b79b9
+fail-under = 100
+
diff --git a/.travis.yml b/.travis.yml
index 80e6fd7..3ca6074 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,25 +1,34 @@
+# Generated from:
+# https://github.com/zopefoundation/meta/tree/master/config/pure-python
language: python
-sudo: false
python:
- - 2.7
- - 3.4
- - 3.5
- - 3.6
- - pypy
- - pypy3
+ - 2.7
+ - pypy
+ - 3.5
+ - 3.6
+ - 3.7
+ - 3.8
+ - pypy3
+
matrix:
- include:
- - python: "3.7"
- dist: xenial
- sudo: true
+ include:
+ - name: "lint"
+ python: 3.7
+ env: TOXENV="lint"
+ - name: "coverage"
+ python: 3.7
+ env: TOXENV="coverage"
+ after_success:
+ - coveralls
+
install:
- - pip install -U pip setuptools
- - pip install -U coverage coveralls
- - pip install -U -e .[test]
+ - pip install -U pip
+ - pip install -U tox-travis coveralls
+
script:
- - coverage run -m zope.testrunner --test-path=src
-after_success:
- - coveralls
+ - tox
+
notifications:
- email: false
+ email: false
+
cache: pip
diff --git a/CHANGES.rst b/CHANGES.rst
index 07a68b0..4ff1e26 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,7 +5,9 @@
2.4 (unreleased)
================
-- Nothing changed yet.
+- Add support for Python 3.8.
+
+- Drop support for Python 3.4.
2.3 (2018-10-05)
diff --git a/MANIFEST.in b/MANIFEST.in
index ce36315..9e5fab2 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,14 +1,21 @@
+# Generated from:
+# https://github.com/zopefoundation/meta/tree/master/config/pure-python
include *.rst
include *.txt
-include tox.ini
-include bootstrap.py
include buildout.cfg
-include .travis.yml
-include .coveragerc
+include tox.ini
+
+exclude MANIFEST.in
-recursive-include src *
+recursive-include docs *.bat
recursive-include docs *.py
recursive-include docs *.rst
recursive-include docs Makefile
-global-exclude *.pyc
+recursive-include src *.gif
+recursive-include src *.pt
+recursive-include src *.py
+recursive-include src *.rst
+recursive-include src *.txt
+recursive-include src *.xml
+recursive-include src *.zcml
diff --git a/bootstrap.py b/bootstrap.py
deleted file mode 100644
index a459921..0000000
--- a/bootstrap.py
+++ /dev/null
@@ -1,210 +0,0 @@
-##############################################################################
-#
-# Copyright (c) 2006 Zope Foundation and Contributors.
-# All Rights Reserved.
-#
-# This software is subject to the provisions of the Zope Public License,
-# Version 2.1 (ZPL). A copy of the ZPL should accompany this distribution.
-# THIS SOFTWARE IS PROVIDED "AS IS" AND ANY AND ALL EXPRESS OR IMPLIED
-# WARRANTIES ARE DISCLAIMED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-# WARRANTIES OF TITLE, MERCHANTABILITY, AGAINST INFRINGEMENT, AND FITNESS
-# FOR A PARTICULAR PURPOSE.
-#
-##############################################################################
-"""Bootstrap a buildout-based project
-
-Simply run this script in a directory containing a buildout.cfg.
-The script accepts buildout command-line options, so you can
-use the -c option to specify an alternate configuration file.
-"""
-
-import os
-import shutil
-import sys
-import tempfile
-
-from optparse import OptionParser
-
-__version__ = '2015-07-01'
-# See zc.buildout's changelog if this version is up to date.
-
-tmpeggs = tempfile.mkdtemp(prefix='bootstrap-')
-
-usage = '''\
-[DESIRED PYTHON FOR BUILDOUT] bootstrap.py [options]
-
-Bootstraps a buildout-based project.
-
-Simply run this script in a directory containing a buildout.cfg, using the
-Python that you want bin/buildout to use.
-
-Note that by using --find-links to point to local resources, you can keep
-this script from going over the network.
-'''
-
-parser = OptionParser(usage=usage)
-parser.add_option("--version",
- action="store_true", default=False,
- help=("Return bootstrap.py version."))
-parser.add_option("-t", "--accept-buildout-test-releases",
- dest='accept_buildout_test_releases',
- action="store_true", default=False,
- help=("Normally, if you do not specify a --version, the "
- "bootstrap script and buildout gets the newest "
- "*final* versions of zc.buildout and its recipes and "
- "extensions for you. If you use this flag, "
- "bootstrap and buildout will get the newest releases "
- "even if they are alphas or betas."))
-parser.add_option("-c", "--config-file",
- help=("Specify the path to the buildout configuration "
- "file to be used."))
-parser.add_option("-f", "--find-links",
- help=("Specify a URL to search for buildout releases"))
-parser.add_option("--allow-site-packages",
- action="store_true", default=False,
- help=("Let bootstrap.py use existing site packages"))
-parser.add_option("--buildout-version",
- help="Use a specific zc.buildout version")
-parser.add_option("--setuptools-version",
- help="Use a specific setuptools version")
-parser.add_option("--setuptools-to-dir",
- help=("Allow for re-use of existing directory of "
- "setuptools versions"))
-
-options, args = parser.parse_args()
-if options.version:
- print("bootstrap.py version %s" % __version__)
- sys.exit(0)
-
-
-######################################################################
-# load/install setuptools
-
-try:
- from urllib.request import urlopen
-except ImportError:
- from urllib2 import urlopen
-
-ez = {}
-if os.path.exists('ez_setup.py'):
- exec(open('ez_setup.py').read(), ez)
-else:
- exec(urlopen('https://bootstrap.pypa.io/ez_setup.py').read(), ez)
-
-if not options.allow_site_packages:
- # ez_setup imports site, which adds site packages
- # this will remove them from the path to ensure that incompatible versions
- # of setuptools are not in the path
- import site
- # inside a virtualenv, there is no 'getsitepackages'.
- # We can't remove these reliably
- if hasattr(site, 'getsitepackages'):
- for sitepackage_path in site.getsitepackages():
- # Strip all site-packages directories from sys.path that
- # are not sys.prefix; this is because on Windows
- # sys.prefix is a site-package directory.
- if sitepackage_path != sys.prefix:
- sys.path[:] = [x for x in sys.path
- if sitepackage_path not in x]
-
-setup_args = dict(to_dir=tmpeggs, download_delay=0)
-
-if options.setuptools_version is not None:
- setup_args['version'] = options.setuptools_version
-if options.setuptools_to_dir is not None:
- setup_args['to_dir'] = options.setuptools_to_dir
-
-ez['use_setuptools'](**setup_args)
-import setuptools
-import pkg_resources
-
-# This does not (always?) update the default working set. We will
-# do it.
-for path in sys.path:
- if path not in pkg_resources.working_set.entries:
- pkg_resources.working_set.add_entry(path)
-
-######################################################################
-# Install buildout
-
-ws = pkg_resources.working_set
-
-setuptools_path = ws.find(
- pkg_resources.Requirement.parse('setuptools')).location
-
-# Fix sys.path here as easy_install.pth added before PYTHONPATH
-cmd = [sys.executable, '-c',
- 'import sys; sys.path[0:0] = [%r]; ' % setuptools_path +
- 'from setuptools.command.easy_install import main; main()',
- '-mZqNxd', tmpeggs]
-
-find_links = os.environ.get(
- 'bootstrap-testing-find-links',
- options.find_links or
- ('http://downloads.buildout.org/'
- if options.accept_buildout_test_releases else None)
- )
-if find_links:
- cmd.extend(['-f', find_links])
-
-requirement = 'zc.buildout'
-version = options.buildout_version
-if version is None and not options.accept_buildout_test_releases:
- # Figure out the most recent final version of zc.buildout.
- import setuptools.package_index
- _final_parts = '*final-', '*final'
-
- def _final_version(parsed_version):
- try:
- return not parsed_version.is_prerelease
- except AttributeError:
- # Older setuptools
- for part in parsed_version:
- if (part[:1] == '*') and (part not in _final_parts):
- return False
- return True
-
- index = setuptools.package_index.PackageIndex(
- search_path=[setuptools_path])
- if find_links:
- index.add_find_links((find_links,))
- req = pkg_resources.Requirement.parse(requirement)
- if index.obtain(req) is not None:
- best = []
- bestv = None
- for dist in index[req.project_name]:
- distv = dist.parsed_version
- if _final_version(distv):
- if bestv is None or distv > bestv:
- best = [dist]
- bestv = distv
- elif distv == bestv:
- best.append(dist)
- if best:
- best.sort()
- version = best[-1].version
-if version:
- requirement = '=='.join((requirement, version))
-cmd.append(requirement)
-
-import subprocess
-if subprocess.call(cmd) != 0:
- raise Exception(
- "Failed to execute command:\n%s" % repr(cmd)[1:-1])
-
-######################################################################
-# Import and run buildout
-
-ws.add_entry(tmpeggs)
-ws.require(requirement)
-import zc.buildout.buildout
-
-if not [a for a in args if '=' not in a]:
- args.append('bootstrap')
-
-# if -c was provided, we push it back into args for buildout' main function
-if options.config_file is not None:
- args[0:0] = ['-c', options.config_file]
-
-zc.buildout.buildout.main(args)
-shutil.rmtree(tmpeggs)
diff --git a/setup.cfg b/setup.cfg
index 2a9acf1..9f7321c 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,2 +1,13 @@
+# Generated from:
+# https://github.com/zopefoundation/meta/tree/master/config/pure-python
[bdist_wheel]
universal = 1
+
+[flake8]
+doctests = 1
+
+[check-manifest]
+ignore =
+ .editorconfig
+ .meta.cfg
+ .travis.yml
diff --git a/setup.py b/setup.py
index 13cab56..49235d3 100644
--- a/setup.py
+++ b/setup.py
@@ -16,10 +16,12 @@ import os
from setuptools import setup, find_packages
+
def read(*rnames):
with open(os.path.join(os.path.dirname(__file__), *rnames)) as f:
return f.read()
+
setup(
name='zope.browser',
version='2.4.dev0',
@@ -42,10 +44,10 @@ setup(
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
@@ -56,7 +58,15 @@ setup(
url='https://zopebrowser.readthedocs.io',
packages=find_packages('src'),
package_dir={'': 'src'},
- namespace_packages=['zope',],
+ namespace_packages=['zope'],
+ python_requires=', '.join([
+ '>=2.7',
+ '!=3.0.*',
+ '!=3.1.*',
+ '!=3.2.*',
+ '!=3.3.*',
+ '!=3.4.*',
+ ]),
install_requires=[
'setuptools',
'zope.interface',
diff --git a/src/zope/__init__.py b/src/zope/__init__.py
index 2e2033b..2a6ee8d 100644
--- a/src/zope/__init__.py
+++ b/src/zope/__init__.py
@@ -1,7 +1 @@
-# this is a namespace package
-try:
- import pkg_resources
- pkg_resources.declare_namespace(__name__)
-except ImportError:
- import pkgutil
- __path__ = pkgutil.extend_path(__path__, __name__)
+__import__('pkg_resources').declare_namespace(__name__) # pragma: nocover
diff --git a/src/zope/browser/interfaces.py b/src/zope/browser/interfaces.py
index ff956c5..8647547 100644
--- a/src/zope/browser/interfaces.py
+++ b/src/zope/browser/interfaces.py
@@ -13,17 +13,17 @@
##############################################################################
"""Shared dependency less Zope3 brwoser components.
"""
-__docformat__ = 'restructuredtext'
-
from zope.interface import Attribute
from zope.interface import Interface
+
class IView(Interface):
""" Views are multi-adapters for context and request objects.
"""
context = Attribute("The context object the view renders")
request = Attribute("The request object driving the view")
+
class IBrowserView(IView):
""" Views which are specialized for requests from a browser
@@ -31,10 +31,12 @@ class IBrowserView(IView):
etc.
"""
+
class IAdding(IBrowserView):
""" Multi-adapter interface for views which add items to containers.
- The 'context' of the view must implement :obj:`zope.container.interfaces.IContainer`.
+ The 'context' of the view must implement
+ :obj:`zope.container.interfaces.IContainer`.
"""
def add(content):
@@ -68,8 +70,7 @@ class IAdding(IBrowserView):
"""
def nameAllowed():
- """Return whether names can be input by the user.
- """
+ """Return whether names can be input by the user."""
def addingInfo():
"""Return add menu data as a sequence of mappings.
@@ -83,7 +84,9 @@ class IAdding(IBrowserView):
"""Return whether there is single menu item or not."""
def hasCustomAddView():
- "This should be called only if there is ``singleMenuItem`` else return 0"
+ """This should be called only if there is ``singleMenuItem``
+ else return 0.
+ """
class ITerms(Interface):
@@ -103,10 +106,10 @@ class ITerms(Interface):
LookupError is raised if there isn't a value in the source.
"""
+
class ISystemErrorView(Interface):
"""Error views that can classify their contexts as system errors
"""
def isSystemError():
- """Return a boolean indicating whether the error is a system errror
- """
+ """Return a boolean indicating whether the error is a system error."""
diff --git a/src/zope/browser/tests.py b/src/zope/browser/tests.py
index a58fe7d..401366c 100644
--- a/src/zope/browser/tests.py
+++ b/src/zope/browser/tests.py
@@ -20,10 +20,6 @@ def test_suite():
return unittest.TestSuite((
doctest.DocFileSuite(
'README.rst',
- optionflags=doctest.NORMALIZE_WHITESPACE|doctest.ELLIPSIS,
+ optionflags=doctest.NORMALIZE_WHITESPACE | doctest.ELLIPSIS,
),
))
-
-
-if __name__ == '__main__':
- unittest.main(defaultTest='test_suite')
diff --git a/tox.ini b/tox.ini
index bcf0e50..622e9dc 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,26 +1,62 @@
+# Generated from:
+# https://github.com/zopefoundation/meta/tree/master/config/pure-python
[tox]
envlist =
- py27,py34,py35,py36,py37,pypy,pypy3,docs,coverage
+ lint,
+ py27,
+ pypy,
+ py35,
+ py36,
+ py37,
+ py38,
+ pypy3,
+ coverage
[testenv]
+usedevelop = true
+deps =
+ zope.testrunner
commands =
zope-testrunner --test-path=src []
+extras = test
+
+[testenv:lint]
+basepython = python3
+skip_install = true
deps =
- .[test]
+ flake8
+ check-manifest
+ check-python-versions
+commands =
+ flake8 src setup.py
+ check-manifest
+ check-python-versions
[testenv:coverage]
-usedevelop = true
-basepython =
- python3.7
-commands =
- coverage run -m zope.testrunner --test-path=src
- coverage report --fail-under=100
+basepython = python3
deps =
- {[testenv]deps}
coverage
-
-[testenv:docs]
+ coverage-python-version
+ zope.testrunner
commands =
- sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
-deps =
- .[docs]
+ coverage run -m zope.testrunner --test-path=src []
+ coverage html
+ coverage report -m --fail-under=100
+
+[coverage:run]
+branch = True
+plugins = coverage_python_version
+source = src
+
+[coverage:report]
+precision = 2
+exclude_lines =
+ pragma: nocover
+ except ImportError:
+ raise NotImplementedError
+ if __name__ == '__main__':
+ self.fail
+ raise AssertionError
+
+[coverage:html]
+directory = htmlcov