summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorchrBrd <chris@binaryspanner.com>2018-07-31 18:44:07 +0100
committerchrBrd <chris@binaryspanner.com>2018-07-31 18:44:57 +0100
commitfd3ac8e7b4189177eb442696375034b11ed9fb6f (patch)
tree0d670e090964fb9c63eea374ee53df46c8866f6f
parent8d1ac16763968312f858da8b05f5f844aff79329 (diff)
downloadxattr-fd3ac8e7b4189177eb442696375034b11ed9fb6f.tar.gz
Shorten tarball test.
-rwxr-xr-x.travis/run.sh14
1 files changed, 5 insertions, 9 deletions
diff --git a/.travis/run.sh b/.travis/run.sh
index a682cc0..206bf68 100755
--- a/.travis/run.sh
+++ b/.travis/run.sh
@@ -20,14 +20,10 @@ fi
if [[ -n "$PYENV_VERSION" && "$TRAVIS_OS_NAME" == 'osx' ]]; then
python setup.py bdist_wheel
fi
+
if [[ "$BUILD_SDIST" == 'true' ]]; then
- python setup.py sdist
- mkdir -p tmp-build
- cd tmp-build
- tar zxvf ../dist/xattr-*.tar.gz
- cd xattr-*
- "$cmd" setup.py build_ext -i
- "$cmd" setup.py test
- cd ../..
- rm -rf tmp-build
+ "$cmd" setup.py sdist --formats=gztar
+ # Ensure the package installs from tarball correctly.
+ filename=$("$cmd" setup.py --fullname)
+ pip install "dist/$filename.tar.gz"
fi