summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2020-01-13 00:55:36 -0800
committerGitHub <noreply@github.com>2020-01-13 00:55:36 -0800
commit81643bb53ec113113ed2c64f6fc2a80e450fc3c5 (patch)
tree39563ce1c994a2f01c8dfc5818fcfe9102c6d635
parent0fb162fcab88020547033a31ab05f8dd64f53eb4 (diff)
parent8669c0b10e87982f8a8dd3eb44ab6df011c6775f (diff)
downloadxattr-81643bb53ec113113ed2c64f6fc2a80e450fc3c5.tar.gz
Merge pull request #89 from jmberg/setup-fix
setup.py: make CLASSIFIERS a list
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index aa79748..0f1af60 100644
--- a/setup.py
+++ b/setup.py
@@ -16,7 +16,7 @@ Extended attributes are currently only available on Darwin 8.0+ (Mac OS X 10.4)
and Linux 2.6+. Experimental support is included for Solaris and FreeBSD.
"""
-CLASSIFIERS = filter(bool, map(str.strip,
+CLASSIFIERS = list(filter(bool, map(str.strip,
"""
Environment :: Console
Intended Audience :: Developers
@@ -29,7 +29,7 @@ Programming Language :: Python
Programming Language :: Python :: 2
Programming Language :: Python :: 3
Topic :: Software Development :: Libraries :: Python Modules
-""".splitlines()))
+""".splitlines())))
setup(
name="xattr",