summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Berg <johannes.berg@intel.com>2020-01-13 09:17:30 +0100
committerJohannes Berg <johannes.berg@intel.com>2020-01-13 09:17:45 +0100
commit8669c0b10e87982f8a8dd3eb44ab6df011c6775f (patch)
tree39563ce1c994a2f01c8dfc5818fcfe9102c6d635
parent0fb162fcab88020547033a31ab05f8dd64f53eb4 (diff)
downloadxattr-8669c0b10e87982f8a8dd3eb44ab6df011c6775f.tar.gz
setup.py: make CLASSIFIERS a list
This fixes: Warning: 'classifiers' should be a list, got type 'filter' during setup.py run if python is python3.
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index aa79748..0f1af60 100644
--- a/setup.py
+++ b/setup.py
@@ -16,7 +16,7 @@ Extended attributes are currently only available on Darwin 8.0+ (Mac OS X 10.4)
and Linux 2.6+. Experimental support is included for Solaris and FreeBSD.
"""
-CLASSIFIERS = filter(bool, map(str.strip,
+CLASSIFIERS = list(filter(bool, map(str.strip,
"""
Environment :: Console
Intended Audience :: Developers
@@ -29,7 +29,7 @@ Programming Language :: Python
Programming Language :: Python :: 2
Programming Language :: Python :: 3
Topic :: Software Development :: Libraries :: Python Modules
-""".splitlines()))
+""".splitlines())))
setup(
name="xattr",