summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2022-12-03 16:10:14 -0800
committerGitHub <noreply@github.com>2022-12-03 16:10:14 -0800
commit0cd5326f2bd1b22f68f0e69b8775aa84915ee656 (patch)
tree384fed8b0f060848fe423fc5b12ef5faa219c48b
parentc675b9e7f5f2add34c965a9ec74e2a4953c45eb9 (diff)
parent86a423cb901c584550468aaddca1357063ceee93 (diff)
downloadxattr-master.tar.gz
Merge pull request #112 from xattr/update-actionsHEADv0.10.1master
Update github actions
-rw-r--r--.github/workflows/build-and-deploy.yml10
-rw-r--r--CHANGES.txt4
2 files changed, 8 insertions, 6 deletions
diff --git a/.github/workflows/build-and-deploy.yml b/.github/workflows/build-and-deploy.yml
index ad5a636..294c97d 100644
--- a/.github/workflows/build-and-deploy.yml
+++ b/.github/workflows/build-and-deploy.yml
@@ -26,12 +26,12 @@ jobs:
- name: Set up QEMU
if: runner.os == 'Linux'
- uses: docker/setup-qemu-action@v1
+ uses: docker/setup-qemu-action@v2
with:
platforms: arm64
- name: Build wheels
- uses: pypa/cibuildwheel@v2.2.2
+ uses: pypa/cibuildwheel@v2.11.2
env:
CIBW_BUILD_FRONTEND: "build"
CIBW_MANYLINUX_X86_64_IMAGE: manylinux2014
@@ -67,7 +67,7 @@ jobs:
- uses: actions/setup-python@v2
name: Install Python
with:
- python-version: '3.9'
+ python-version: '3.11'
- name: Build sdist
run: python setup.py sdist
@@ -90,7 +90,7 @@ jobs:
name: artifact
path: dist
- - uses: pypa/gh-action-pypi-publish@v1.4.2
+ - uses: pypa/gh-action-pypi-publish@v1.6.1
with:
user: __token__
password: ${{ secrets.PYPI_PASSWORD }}
@@ -109,7 +109,7 @@ jobs:
name: artifact
path: dist
- - uses: pypa/gh-action-pypi-publish@v1.4.2
+ - uses: pypa/gh-action-pypi-publish@v1.6.1
with:
user: __token__
password: ${{ secrets.PYPI_PASSWORD_TEST }}
diff --git a/CHANGES.txt b/CHANGES.txt
index ae92961..5f1fa59 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,5 +1,7 @@
-Version 0.10.1 released XXXX-XX-XX
+Version 0.10.1 released 2022-12-03
+* Update github actions
+ https://github.com/xattr/xattr/issues/112
* Updated README to add reference to osxmetadata
https://github.com/xattr/xattr/pull/110