summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2017-07-07 17:03:28 -0700
committerJon Dufresne <jon.dufresne@gmail.com>2017-07-07 17:03:28 -0700
commit63ad63cc2122069ae6ff8f28cfbfd87953c91ae0 (patch)
treeab76faee0c3c2650a9168a49fb8c00b628b93968
parent27d4d39efbdea59aafa38e46bfad2601595ce005 (diff)
downloadwheel-63ad63cc2122069ae6ff8f28cfbfd87953c91ae0.tar.gz
Drop support for Python 2.6
-rw-r--r--CHANGES.txt4
-rw-r--r--METADATA.in8
-rw-r--r--setup.py6
-rw-r--r--tox.ini5
-rw-r--r--wheel/bdist_wheel.py6
-rw-r--r--wheel/metadata.py5
-rw-r--r--wheel/pep425tags.py6
-rw-r--r--wheel/util.py5
8 files changed, 16 insertions, 29 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index f53b572..1024db1 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,3 +1,7 @@
+UNRELEASED
+==========
+- Remove support for Python 2.6.
+
0.29.0
======
- Fix compression type of files in archive (Issue #155, Pull Request #62,
diff --git a/METADATA.in b/METADATA.in
index 2827551..18ebf32 100644
--- a/METADATA.in
+++ b/METADATA.in
@@ -8,16 +8,20 @@ Author-email: dholth@fastmail.fm
License: MIT
Keywords: wheel,packaging
Platform: UNKNOWN
-Classifier: Development Status :: 4 - Beta
+Classifier: Development Status :: 5 - Production/Stable
Classifier: Intended Audience :: Developers
+Classifier: License :: OSI Approved :: MIT License
Classifier: Programming Language :: Python
Classifier: Programming Language :: Python :: 2
-Classifier: Programming Language :: Python :: 2.6
Classifier: Programming Language :: Python :: 2.7
Classifier: Programming Language :: Python :: 3
Classifier: Programming Language :: Python :: 3.2
Classifier: Programming Language :: Python :: 3.3
Classifier: Programming Language :: Python :: 3.4
+Classifier: Programming Language :: Python :: 3.5
+Classifier: Programming Language :: Python :: 3.6
+Classifier: Programming Language :: Python :: Implementation :: CPython
+Classifier: Programming Language :: Python :: Implementation :: PyPy
Provides-Extra: tool
Provides-Extra: signatures
Requires-Dist: keyring; extra == 'signatures'
diff --git a/setup.py b/setup.py
index ccc6908..2d77f51 100644
--- a/setup.py
+++ b/setup.py
@@ -20,7 +20,6 @@ setup(name='wheel',
"License :: OSI Approved :: MIT License",
"Programming Language :: Python",
"Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.2",
@@ -43,16 +42,13 @@ setup(name='wheel',
'wheel.signatures'
],
extras_require={
- ':python_version=="2.6"': ['argparse'],
'signatures': ['keyring', 'keyrings.alt'],
'signatures:sys_platform!="win32"': ['pyxdg'],
- 'signatures:python_version=="2.6"': ['importlib'],
'faster-signatures': ['ed25519ll'],
'tool': []
},
tests_require=[
- # Newer versions of jsonschema do not support Python 2.6.
- 'jsonschema<2.6.0',
+ 'jsonschema',
'pytest',
'coverage',
'pytest-cov',
diff --git a/tox.ini b/tox.ini
index 82f7299..309d58d 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,15 +4,14 @@
# and then run "tox" from this directory.
[tox]
-envlist = py26, py27, pypy, py33, py34, py35, py36
+envlist = py27, pypy, py33, py34, py35, py36
[testenv]
commands =
py.test
deps =
.[tool,signatures]
- # Newer versions of jsonschema do not support Python 2.6.
- jsonschema<2.6.0
+ jsonschema
pytest
pytest-cov
setuptools>3.0
diff --git a/wheel/bdist_wheel.py b/wheel/bdist_wheel.py
index d716163..f45270a 100644
--- a/wheel/bdist_wheel.py
+++ b/wheel/bdist_wheel.py
@@ -13,12 +13,6 @@ import shutil
import json
import sys
-try:
- import sysconfig
-except ImportError: # pragma nocover
- # Python < 2.7
- import distutils.sysconfig as sysconfig
-
import pkg_resources
safe_name = pkg_resources.safe_name
diff --git a/wheel/metadata.py b/wheel/metadata.py
index fd2bb7e..e68d621 100644
--- a/wheel/metadata.py
+++ b/wheel/metadata.py
@@ -5,10 +5,7 @@ Tools for converting old- to new-style metadata.
from collections import namedtuple
from .pkginfo import read_pkg_info
from .util import OrderedDefaultDict
-try:
- from collections import OrderedDict
-except ImportError:
- OrderedDict = dict
+from collections import OrderedDict
import re
import os.path
diff --git a/wheel/pep425tags.py b/wheel/pep425tags.py
index 5ac5d0d..704afaa 100644
--- a/wheel/pep425tags.py
+++ b/wheel/pep425tags.py
@@ -3,11 +3,7 @@
import sys
import warnings
-try:
- import sysconfig
-except ImportError: # pragma nocover
- # Python < 2.7
- import distutils.sysconfig as sysconfig
+import sysconfig
import distutils.util
diff --git a/wheel/util.py b/wheel/util.py
index 5268813..20f386f 100644
--- a/wheel/util.py
+++ b/wheel/util.py
@@ -5,10 +5,7 @@ import os
import base64
import json
import hashlib
-try:
- from collections import OrderedDict
-except ImportError:
- OrderedDict = dict
+from collections import OrderedDict
__all__ = ['urlsafe_b64encode', 'urlsafe_b64decode', 'utf8',
'to_json', 'from_json', 'matches_requirement']