summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2017-06-04 13:58:07 -0700
committerJon Dufresne <jon.dufresne@gmail.com>2017-06-04 13:58:07 -0700
commit27d4d39efbdea59aafa38e46bfad2601595ce005 (patch)
treed5ad78f0bbfe72a8237ae0ca75eba49a72813247
parent6cf95a60b3c7ae44cc1f4835b4a5153ae508d084 (diff)
downloadwheel-27d4d39efbdea59aafa38e46bfad2601595ce005.tar.gz
Document support for Python 3.6 and add it to the testing matrix
Pin jsonschema to allow tests to pass on Python 2.6.
-rw-r--r--setup.py36
-rw-r--r--tox.ini5
2 files changed, 26 insertions, 15 deletions
diff --git a/setup.py b/setup.py
index fc27b85..ccc6908 100644
--- a/setup.py
+++ b/setup.py
@@ -15,17 +15,22 @@ setup(name='wheel',
description='A built-package format for Python.',
long_description=README + '\n\n' + CHANGES,
classifiers=[
- "Development Status :: 4 - Beta",
- "Intended Audience :: Developers",
- "Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.6",
- "Programming Language :: Python :: 2.7",
- "Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.2",
- "Programming Language :: Python :: 3.3",
- "Programming Language :: Python :: 3.4",
- ],
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.2",
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
+ ],
author='Daniel Holth',
author_email='dholth@fastmail.fm',
url='https://bitbucket.org/pypa/wheel/',
@@ -45,7 +50,13 @@ setup(name='wheel',
'faster-signatures': ['ed25519ll'],
'tool': []
},
- tests_require=['jsonschema', 'pytest', 'coverage', 'pytest-cov'],
+ tests_require=[
+ # Newer versions of jsonschema do not support Python 2.6.
+ 'jsonschema<2.6.0',
+ 'pytest',
+ 'coverage',
+ 'pytest-cov',
+ ],
include_package_data=True,
zip_safe=False,
entry_points = """\
@@ -55,4 +66,3 @@ wheel = wheel.tool:main
[distutils.commands]
bdist_wheel = wheel.bdist_wheel:bdist_wheel"""
)
-
diff --git a/tox.ini b/tox.ini
index 9590ab4..82f7299 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,14 +4,15 @@
# and then run "tox" from this directory.
[tox]
-envlist = py26, py27, pypy, py33, py34, py35
+envlist = py26, py27, pypy, py33, py34, py35, py36
[testenv]
commands =
py.test
deps =
.[tool,signatures]
- jsonschema
+ # Newer versions of jsonschema do not support Python 2.6.
+ jsonschema<2.6.0
pytest
pytest-cov
setuptools>3.0