summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Holth <dholth@fastmail.fm>2016-09-14 18:15:10 -0400
committerDaniel Holth <dholth@fastmail.fm>2016-09-14 18:15:10 -0400
commit0fac6fbefc25e3dfb8f6e49a06629f059258780d (patch)
tree66aeb193a0795e7348560d584d2edfef8467062e
parent2ad4bf75f76d91e4407ce7175130790199020b60 (diff)
downloadwheel-0fac6fbefc25e3dfb8f6e49a06629f059258780d.tar.gz
use dict-format entry_points
-rw-r--r--setup.py14
1 files changed, 8 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index fc27b85..bd1c900 100644
--- a/setup.py
+++ b/setup.py
@@ -48,11 +48,13 @@ setup(name='wheel',
tests_require=['jsonschema', 'pytest', 'coverage', 'pytest-cov'],
include_package_data=True,
zip_safe=False,
- entry_points = """\
-[console_scripts]
-wheel = wheel.tool:main
-
-[distutils.commands]
-bdist_wheel = wheel.bdist_wheel:bdist_wheel"""
+ entry_points = {
+ 'console_scripts': [
+ 'wheel=wheel.tool:main'
+ ],
+ 'distutils.commands': [
+ 'bdist_wheel=wheel.bdist_wheel:bdist_wheel'
+ ]
+ }
)