summaryrefslogtreecommitdiff
path: root/README.md
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2020-12-15 16:10:43 +0100
committerPierre Ossman <ossman@cendio.se>2020-12-15 16:10:43 +0100
commit108f993eb387d10fbc6ebb632f4fb92c8c44a15b (patch)
tree45751cb77786d1d0c6b3d41a3d49b44b36bc877a /README.md
parent33710b397230e239a202c650ceaa8148a1a45c01 (diff)
downloadwebsockify-108f993eb387d10fbc6ebb632f4fb92c8c44a15b.tar.gz
Explicitly request Python 3
It varies between systems if /usr/bin/python is Python 2.x or Python 3.x. Since we now only work with Python 3.x we should be more explicit in our scripts and documentation.
Diffstat (limited to 'README.md')
-rw-r--r--README.md4
1 files changed, 2 insertions, 2 deletions
diff --git a/README.md b/README.md
index 118f97c..6861f4c 100644
--- a/README.md
+++ b/README.md
@@ -159,12 +159,12 @@ project demonstrates a simple WebSockets based telnet client (use
### Installing websockify
Download one of the releases or the latest development version, extract
-it and run `python setup.py install` as root in the directory where you
+it and run `python3 setup.py install` as root in the directory where you
extracted the files. Normally, this will also install numpy for better
performance, if you don't have it installed already. However, numpy is
optional. If you don't want to install numpy or if you can't compile it,
you can edit setup.py and remove the `install_requires=['numpy'],` line
-before running `python setup.py install`.
+before running `python3 setup.py install`.
Afterwards, websockify should be available in your path. Run
`websockify --help` to confirm it's installed correctly.