summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2020-12-15 16:10:43 +0100
committerPierre Ossman <ossman@cendio.se>2020-12-15 16:10:43 +0100
commit108f993eb387d10fbc6ebb632f4fb92c8c44a15b (patch)
tree45751cb77786d1d0c6b3d41a3d49b44b36bc877a
parent33710b397230e239a202c650ceaa8148a1a45c01 (diff)
downloadwebsockify-108f993eb387d10fbc6ebb632f4fb92c8c44a15b.tar.gz
Explicitly request Python 3
It varies between systems if /usr/bin/python is Python 2.x or Python 3.x. Since we now only work with Python 3.x we should be more explicit in our scripts and documentation.
-rw-r--r--.travis.yml2
-rw-r--r--README.md4
-rwxr-xr-xrun2
3 files changed, 4 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index 62e88a5..79a2845 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -6,4 +6,4 @@ install:
- pip install 'setuptools>=18.5,<=39.0.0'
- pip install -r test-requirements.txt
-script: python setup.py nosetests --verbosity=3
+script: python3 setup.py nosetests --verbosity=3
diff --git a/README.md b/README.md
index 118f97c..6861f4c 100644
--- a/README.md
+++ b/README.md
@@ -159,12 +159,12 @@ project demonstrates a simple WebSockets based telnet client (use
### Installing websockify
Download one of the releases or the latest development version, extract
-it and run `python setup.py install` as root in the directory where you
+it and run `python3 setup.py install` as root in the directory where you
extracted the files. Normally, this will also install numpy for better
performance, if you don't have it installed already. However, numpy is
optional. If you don't want to install numpy or if you can't compile it,
you can edit setup.py and remove the `install_requires=['numpy'],` line
-before running `python setup.py install`.
+before running `python3 setup.py install`.
Afterwards, websockify should be available in your path. Run
`websockify --help` to confirm it's installed correctly.
diff --git a/run b/run
index 8078ce9..8032dd2 100755
--- a/run
+++ b/run
@@ -1,4 +1,4 @@
#!/usr/bin/env sh
set -e
cd "$(dirname "$0")"
-exec python -m websockify "$@"
+exec python3 -m websockify "$@"