summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2019-07-29 12:05:53 -0500
committerJason Madden <jamadden@gmail.com>2019-07-29 12:05:53 -0500
commitcd162671d51427981cb40bb1866fcd81b25fcd0f (patch)
treea7cccb7e410c6294d543cf04e032e475cedc809b
parent6d0a8772af9b721d167f498817575acf4042c679 (diff)
downloadtrollius-git-cd162671d51427981cb40bb1866fcd81b25fcd0f.tar.gz
Metadata updates.
Be explicit about supporting only Python 2.7 Drop testing on appveyor because the needed dependencies no longer exist. Incorporate https://github.com/vstinner/trollius/pull/15/
-rw-r--r--MANIFEST.in1
-rw-r--r--README.rst46
-rw-r--r--appveyor.yml32
-rw-r--r--doc/changelog.rst15
-rw-r--r--setup.py91
-rw-r--r--trollius/selectors.py3
6 files changed, 57 insertions, 131 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 9dabbdc..5d4033f 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -4,6 +4,7 @@ include overlapped.c pypi.bat
include check.py runtests.py release.py
include update-asyncio-*.sh
include .travis.yml
+include appveyor.yml
include releaser.conf
include doc/conf.py doc/make.bat doc/Makefile
diff --git a/README.rst b/README.rst
index 773d056..79764d3 100644
--- a/README.rst
+++ b/README.rst
@@ -7,47 +7,5 @@ Trollius
:alt: No Maintenance Intended
.. warning::
- The Trollius project is deprecated since the release 2.1.! Use asyncio on
- Python 3 instead.
-
-Trollius provides infrastructure for writing single-threaded concurrent
-code using coroutines, multiplexing I/O access over sockets and other
-resources, running network clients and servers, and other related primitives.
-Here is a more detailed list of the package contents:
-
-* a pluggable event loop with various system-specific implementations;
-
-* transport and protocol abstractions (similar to those in `Twisted
- <http://twistedmatrix.com/>`_);
-
-* concrete support for TCP, UDP, SSL, subprocess pipes, delayed calls, and
- others (some may be system-dependent);
-
-* a ``Future`` class that mimics the one in the ``concurrent.futures`` module,
- but adapted for use with the event loop;
-
-* coroutines and tasks based on generators (``yield``), to help write
- concurrent code in a sequential fashion;
-
-* cancellation support for ``Future``\s and coroutines;
-
-* synchronization primitives for use between coroutines in a single thread,
- mimicking those in the ``threading`` module;
-
-* an interface for passing work off to a threadpool, for times when you
- absolutely, positively have to use a library that makes blocking I/O calls.
-
-Trollius is a portage of the `asyncio project
-<https://github.com/python/asyncio>`_ (`PEP 3156
-<http://legacy.python.org/dev/peps/pep-3156/>`_) on Python 2. Trollius works on
-Python 2.6-3.5. It has been tested on Windows, Linux, Mac OS X, FreeBSD and
-OpenIndiana.
-
-* `Asyncio documentation <http://docs.python.org/dev/library/asyncio.html>`_
-* `Trollius project in the Python Cheeseshop (PyPI)
- <https://pypi.python.org/pypi/trollius>`_
-* `Trollius project at Github <https://github.com/vstinner/trollius>`_
- (bug tracker, source code)
-* Copyright/license: Open source, Apache 2.0. Enjoy!
-
-See also the `asyncio project at Github <https://github.com/python/asyncio>`_.
+ The Trollius project is deprecated and unsupported. It is on PyPI
+ to support existing dependencies only.
diff --git a/appveyor.yml b/appveyor.yml
index 41fd792..255b638 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -1,12 +1,14 @@
-version: build-{build}-{branch}
-
environment:
matrix:
- # http://www.appveyor.com/docs/installed-software#python lists available
- # versions
- - PYTHON: "C:\\Python27"
- PYTHON: "C:\\Python27-x64"
- # 32-bit
+ PYTHON_VERSION: "2.7.x" # currently 2.7.13
+ PYTHON_ARCH: "64"
+ PYTHON_EXE: python
+ - PYTHON: "C:\\Python27"
+ PYTHON_VERSION: "2.7.x" # currently 2.7.13
+ PYTHON_ARCH: "32"
+ PYTHON_EXE: python
+ GWHEEL_ONLY: true
- PYTHON: "C:\\pypy2.7-v7.1.0-win32"
PYTHON_ID: "pypy"
PYTHON_EXE: pypy
@@ -15,15 +17,25 @@ environment:
install:
- "set PATH=%PYTHON%;%PYTHON%\\Scripts;%PATH%"
- - python --version
- - pip install wheel aiotest futures mock six unittest2
- - pip install -e .
+ - "SET PATH=%PYTHON%;%PYTHON%\\Scripts;%PYTHON%\\bin;%PATH%"
+ - "SET PYEXE=%PYTHON%\\%PYTHON_EXE%.exe"
+
+ # Check that we have the expected version and architecture for Python
+ - "%PYEXE% --version"
+
+ - "%PYEXE% -m pip install --disable-pip-version-check -U pip"
+ - "%PYEXE% -m pip install -U setuptools wheel"
build_script:
- python setup.py bdist_wheel
+# Theer's nothing to actually test anymore; the aiotest dependency is gone.
test_script:
- - python runtests.py
+ - python --version
artifacts:
- path: dist/*.whl
+
+cache:
+ - "%TMP%\\py\\"
+ - '%LOCALAPPDATA%\pip\Cache'
diff --git a/doc/changelog.rst b/doc/changelog.rst
index 3170470..710625a 100644
--- a/doc/changelog.rst
+++ b/doc/changelog.rst
@@ -1,10 +1,18 @@
-++++++++++
-Change log
-++++++++++
+============
+ Change log
+============
.. warning::
:ref:`The Trollius project is now deprecated! <deprecated>`
+Version 2.3 (2019-07-29)
+========================
+
+This is a packaging-only release. It is intended to be the last
+release.
+
+- Release Windows wheels.
+
Version 2.2 (2018-03-09)
========================
@@ -712,4 +720,3 @@ Other changes of Tulip 0.4.1:
=======================
- First public release
-
diff --git a/setup.py b/setup.py
index 569ca50..015b7e5 100644
--- a/setup.py
+++ b/setup.py
@@ -1,46 +1,6 @@
-# Prepare a release:
-#
-# - git pull --rebase
-# - fill trollius changelog
-# - run maybe ./update-asyncio-step1.sh
-# - run all tests on Linux: tox
-# - run tests on Windows
-# - test examples
-# - check that "python setup.py sdist" contains all files tracked by
-# the SCM (Mercurial): update MANIFEST.in if needed
-# - run test on Windows: releaser.py test
-# - update version in setup.py (version) and doc/conf.py (version, release)
-# - set release date in doc/changelog.rst
-# - git commit
-# - git push
-#
-# Release a new version:
-#
-# - git tag trollius-VERSION
-# - git push --tags
-# - Remove untracked files/dirs: git clean -fdx
-# - On Linux: python2 setup.py sdist
-# FIXME: don't use bdist_wheel because of
-# FIXME: https://github.com/haypo/trollius/issues/1
-# - twine upload dist/*
-# - On Windows: python releaser.py release
-#
-# After the release:
-#
-# - increment version in setup.py (version) and doc/conf.py (version, release)
-# - git commit -a -m "post release X.Y"
-# - git push
-
import os
import sys
-try:
- from setuptools import setup, Extension
- SETUPTOOLS = True
-except ImportError:
- SETUPTOOLS = False
- # Use distutils.core as a fallback.
- # We won't be able to build the Wheel file on Windows.
- from distutils.core import setup, Extension
+from setuptools import setup, Extension
with open("README.rst") as fp:
long_description = fp.read()
@@ -53,40 +13,27 @@ if os.name == 'nt':
extensions.append(ext)
requirements = ['six']
-if sys.version_info < (2, 7):
- requirements.append('ordereddict')
if sys.version_info < (3,):
requirements.append('futures')
-install_options = {
- "name": "trollius",
- "version": "2.3",
- "license": "Apache License 2.0",
- "author": 'Victor Stinner',
- "author_email": 'victor.stinner@gmail.com',
-
- "description": "Port of the Tulip project (asyncio module, PEP 3156) on Python 2",
- "long_description": long_description,
- "url": "https://github.com/haypo/trollius",
-
- "classifiers": [
+setup(
+ name="trollius",
+ version="2.3",
+ license="Apache License 2.0",
+ author='Victor Stinner',
+ author_email='victor.stinner@gmail.com',
+ description="Deprecated, unmaintained port of the asyncio module (PEP 3156) on Python 2",
+ long_description=long_description,
+ url="https://github.com/jamadden/trollius",
+ classifiers=[
"Programming Language :: Python",
- "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 2.7",
"License :: OSI Approved :: Apache Software License",
],
-
- "packages": ["trollius"],
- "test_suite": "runtests.runtests",
-
- "ext_modules": extensions,
-}
-if SETUPTOOLS:
- install_options['install_requires'] = requirements
-
-print("!!! WARNING !!! The Trollius project is now deprecated!")
-print("")
-
-setup(**install_options)
-
-print("")
-print("!!! WARNING !!! The Trollius project is now deprecated!")
+ packages=[
+ "trollius",
+ ],
+ ext_modules=extensions,
+ install_requires=requirements,
+ python_requires=">=2.7, < 3",
+)
diff --git a/trollius/selectors.py b/trollius/selectors.py
index cf0475d..2b24e5e 100644
--- a/trollius/selectors.py
+++ b/trollius/selectors.py
@@ -309,7 +309,8 @@ class SelectSelector(_BaseSelectorImpl):
r, w, x = select.select(r, w, w, timeout)
return r, w + x, []
else:
- _select = select.select
+ def _select(self, r, w, x, timeout=None):
+ return select.select(r, w, x, timeout)
def select(self, timeout=None):
timeout = None if timeout is None else max(timeout, 0)