summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2019-07-29 11:42:09 -0500
committerJason Madden <jamadden@gmail.com>2019-07-29 11:42:09 -0500
commit6d0a8772af9b721d167f498817575acf4042c679 (patch)
tree12fbb54f918af53ef99599d95103af552a394ca5
parent479788fb7b568c0c685599e55e0e98cab9fe474c (diff)
downloadtrollius-git-6d0a8772af9b721d167f498817575acf4042c679.tar.gz
Add appveyor.yml from https://github.com/vstinner/trollius/pull/13/files
-rw-r--r--appveyor.yml29
1 files changed, 29 insertions, 0 deletions
diff --git a/appveyor.yml b/appveyor.yml
new file mode 100644
index 0000000..41fd792
--- /dev/null
+++ b/appveyor.yml
@@ -0,0 +1,29 @@
+version: build-{build}-{branch}
+
+environment:
+ matrix:
+ # http://www.appveyor.com/docs/installed-software#python lists available
+ # versions
+ - PYTHON: "C:\\Python27"
+ - PYTHON: "C:\\Python27-x64"
+ # 32-bit
+ - PYTHON: "C:\\pypy2.7-v7.1.0-win32"
+ PYTHON_ID: "pypy"
+ PYTHON_EXE: pypy
+ PYTHON_VERSION: "2.7.x"
+ PYTHON_ARCH: "32"
+
+install:
+ - "set PATH=%PYTHON%;%PYTHON%\\Scripts;%PATH%"
+ - python --version
+ - pip install wheel aiotest futures mock six unittest2
+ - pip install -e .
+
+build_script:
+ - python setup.py bdist_wheel
+
+test_script:
+ - python runtests.py
+
+artifacts:
+ - path: dist/*.whl