summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xCHANGELOG16
-rw-r--r--doc/announce/release-1.4.3.txt9
-rw-r--r--doc/support.txt2
-rw-r--r--setup.py2
-rw-r--r--tox.ini2
5 files changed, 16 insertions, 15 deletions
diff --git a/CHANGELOG b/CHANGELOG
index d0e5d4b..12a8487 100755
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,8 +1,8 @@
1.4.3
-----------------
-- use pip-script.py instead of pip.exe on win32 to avoid the lock exe file on execution issue
- (thanks Philip Thiem)
+- use pip-script.py instead of pip.exe on win32 to avoid the lock exe
+ file on execution issue (thanks Philip Thiem)
- introduce -l|--listenv option to list configured environments
(thanks Lukasz Balcerzak)
@@ -15,13 +15,13 @@
- fix issue84 - pypy on windows creates a bin not a scripts venv directory
(thanks Lukasz Balcerzak)
-- experimentally introduce --installpkg=PATH option to install a package rather than
- create/install an sdist package. This will still require and use
- tox.ini and tests from the current working dir (and not from the remote
- package).
+- experimentally introduce --installpkg=PATH option to install a package
+ rather than create/install an sdist package. This will still require
+ and use tox.ini and tests from the current working dir (and not from the
+ remote package).
-- substitute {envsitepackagesdir} with the package installation directory (closes #72)
- (thanks g2p)
+- substitute {envsitepackagesdir} with the package installation
+ directory (closes #72) (thanks g2p)
- issue #70 remove PYTHONDONTWRITEBYTECODE workaround now that
virtualenv behaves properly (thanks g2p)
diff --git a/doc/announce/release-1.4.3.txt b/doc/announce/release-1.4.3.txt
index 405e9c7..ca0bb19 100644
--- a/doc/announce/release-1.4.3.txt
+++ b/doc/announce/release-1.4.3.txt
@@ -11,7 +11,8 @@ tox 1.4.3 fixes some bugs and introduces a new script and two new options:
- (experimental) "--installpkg=localpath" option which will skip the
sdist-creation of a package and instead install the given localpath package.
-- use pip-script.py instead of pip.exe on win32 to avoid windows locking the .exe
+- use pip-script.py instead of pip.exe on win32 to avoid windows locking
+ the .exe
Note that the sister project "detox" should continue to work - it's a
separately released project which drives tox test runs on multiple CPUs
@@ -25,7 +26,7 @@ Installation:
pip install -U tox
-code hosting and issue tracking on bitbucket:
+repository hosting and issue tracking on bitbucket:
https://bitbucket.org/hpk42/tox
@@ -33,8 +34,8 @@ code hosting and issue tracking on bitbucket:
What is tox?
----------------
-tox standardizes and automates tedious test activities driven from a
-simple ``tox.ini`` file, including:
+tox standardizes and automates tedious python driven test activities
+driven from a simple ``tox.ini`` file, including:
* creation and management of different virtualenv environments
with different Python interpreters
diff --git a/doc/support.txt b/doc/support.txt
index fd2c3fa..1ece16a 100644
--- a/doc/support.txt
+++ b/doc/support.txt
@@ -30,7 +30,7 @@ experienced `well-known Python developers`_.
.. _`holger's twitter presence`: http://twitter.com/hpk42
.. _`merlinux.eu`: http://merlinux.eu
.. _`report on the issue tracker`: https://bitbucket.org/hpk42/tox/issues?status=new&status=open
-.. _`tetamap blog`: http://tetamap.wordpress.com
+.. _`tetamap blog`: http://holgerkrekel.net
.. _`tox-dev`: http://codespeak.net/mailman/listinfo/tox-dev
.. _`tox-commit`: http://codespeak.net/mailman/listinfo/tox-commit
.. _`clone the mercurial repository`: https://bitbucket.org/hpk42/tox
diff --git a/setup.py b/setup.py
index 15fafea..de3d573 100644
--- a/setup.py
+++ b/setup.py
@@ -41,7 +41,7 @@ class Tox(TestCommand):
def main():
version = sys.version_info[:2]
- install_requires = ['virtualenv>=1.8.4', 'py>=1.4.9', ]
+ install_requires = ['virtualenv>=1.8.4', 'py>=1.4.12', ]
if version < (2, 7) or (3, 0) <= version <= (3, 1):
install_requires += ['argparse']
setup(
diff --git a/tox.ini b/tox.ini
index 331b838..05be67a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist=py27,py26,py25,py31,py32,py33,docs
+envlist=py27,py26,py25,py32,py33,docs,pypy
indexserver =
testrun = http://pypi.testrun.org
pypi = https://pypi.python.org/simple