summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernát Gábor <gaborjbernat@gmail.com>2023-04-13 11:54:02 -0700
committerGitHub <noreply@github.com>2023-04-13 11:54:02 -0700
commitbc6bc6a2e5ac608d9c6f0de5810a619a31fd101f (patch)
tree2ccd7b4d0db84e6cacc3812f423e528667beaa81
parent02901007d8fba21de4ebc486f9692c56c8728af8 (diff)
downloadtox-git-release-4.4.12.tar.gz
Bump deps and tools (#2981)release-4.4.12
-rw-r--r--.pre-commit-config.yaml2
-rw-r--r--pyproject.toml8
-rw-r--r--tox.ini18
3 files changed, 14 insertions, 14 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 745b1c40..29b28291 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -43,7 +43,7 @@ repos:
hooks:
- id: rst-backticks
- repo: https://github.com/tox-dev/tox-ini-fmt
- rev: "1.0.0"
+ rev: "1.3.0"
hooks:
- id: tox-ini-fmt
args: ["-p", "fix"]
diff --git a/pyproject.toml b/pyproject.toml
index 0a084741..19ee5ec5 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -2,7 +2,7 @@
build-backend = "hatchling.build"
requires = [
"hatch-vcs>=0.3",
- "hatchling>=1.13",
+ "hatchling>=1.14",
]
[project]
@@ -51,8 +51,8 @@ dependencies = [
"cachetools>=5.3",
"chardet>=5.1",
"colorama>=0.4.6",
- "filelock>=3.10.7",
- 'importlib-metadata>=6.1; python_version < "3.8"',
+ "filelock>=3.11",
+ 'importlib-metadata>=6.2; python_version < "3.8"',
"packaging>=23",
"platformdirs>=3.2",
"pluggy>=1",
@@ -79,7 +79,7 @@ optional-dependencies.testing = [
"distlib>=0.3.6",
"flaky>=3.7",
"hatch-vcs>=0.3",
- "hatchling>=1.13",
+ "hatchling>=1.14",
"psutil>=5.9.4",
"pytest>=7.2.2",
"pytest-cov>=4",
diff --git a/tox.ini b/tox.ini
index 61f87461..89812ed8 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,7 @@
[tox]
-minversion = 3.22
-envlist =
+requires =
+ tox>=4.2
+env_list =
fix
py311
py310
@@ -11,7 +12,6 @@ envlist =
type
docs
pkg_meta
-isolated_build = true
skip_missing_interpreters = true
[testenv]
@@ -20,10 +20,10 @@ package = wheel
wheel_build_env = .pkg
extras =
testing
-passenv =
+pass_env =
PYTEST_*
SSL_CERT_FILE
-setenv =
+set_env =
COVERAGE_FILE = {env:COVERAGE_FILE:{toxworkdir}{/}.coverage.{envname}}
COVERAGE_PROCESS_START = {toxinidir}{/}pyproject.toml
commands =
@@ -40,8 +40,8 @@ commands =
description = format the code base to adhere to our styles, and complain about what we cannot do automatically
skip_install = true
deps =
- pre-commit>=3.2.1
-passenv =
+ pre-commit>=3.2.2
+pass_env =
{[testenv]passenv}
PROGRAMDATA
commands =
@@ -51,7 +51,7 @@ commands =
[testenv:type]
description = run type check on code base
deps =
- mypy==1.1.1
+ mypy==1.2
types-cachetools>=5.3.0.5
types-chardet>=5.0.4.3
commands =
@@ -90,7 +90,7 @@ commands =
[testenv:dev]
description = dev environment with all deps at {envdir}
-usedevelop = true
+package = editable
deps =
{[testenv:release]deps}
extras =