summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini18
1 files changed, 9 insertions, 9 deletions
diff --git a/tox.ini b/tox.ini
index 61f87461..89812ed8 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,7 @@
[tox]
-minversion = 3.22
-envlist =
+requires =
+ tox>=4.2
+env_list =
fix
py311
py310
@@ -11,7 +12,6 @@ envlist =
type
docs
pkg_meta
-isolated_build = true
skip_missing_interpreters = true
[testenv]
@@ -20,10 +20,10 @@ package = wheel
wheel_build_env = .pkg
extras =
testing
-passenv =
+pass_env =
PYTEST_*
SSL_CERT_FILE
-setenv =
+set_env =
COVERAGE_FILE = {env:COVERAGE_FILE:{toxworkdir}{/}.coverage.{envname}}
COVERAGE_PROCESS_START = {toxinidir}{/}pyproject.toml
commands =
@@ -40,8 +40,8 @@ commands =
description = format the code base to adhere to our styles, and complain about what we cannot do automatically
skip_install = true
deps =
- pre-commit>=3.2.1
-passenv =
+ pre-commit>=3.2.2
+pass_env =
{[testenv]passenv}
PROGRAMDATA
commands =
@@ -51,7 +51,7 @@ commands =
[testenv:type]
description = run type check on code base
deps =
- mypy==1.1.1
+ mypy==1.2
types-cachetools>=5.3.0.5
types-chardet>=5.0.4.3
commands =
@@ -90,7 +90,7 @@ commands =
[testenv:dev]
description = dev environment with all deps at {envdir}
-usedevelop = true
+package = editable
deps =
{[testenv:release]deps}
extras =