summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2022-11-05 21:54:41 +0000
committerJelmer Vernooij <jelmer@jelmer.uk>2022-11-05 21:54:41 +0000
commitaee1c7963691f5523eb72060e53e4ca255a00566 (patch)
tree0d1b3bc69edafb185047ee43639516f7c6559d85
parent5169aa4140707681030eec1f9f4c67e36bfdbbd5 (diff)
downloadsubunit-git-aee1c7963691f5523eb72060e53e4ca255a00566.tar.gz
Release 1.4.11.4.1
-rw-r--r--NEWS24
-rw-r--r--configure.ac2
-rw-r--r--python/subunit/__init__.py2
3 files changed, 26 insertions, 2 deletions
diff --git a/NEWS b/NEWS
index a5c58b1..e771d56 100644
--- a/NEWS
+++ b/NEWS
@@ -8,6 +8,15 @@ NEXT (In development)
IMPROVEMENTS
~~~~~~~~~~~~
+BUG FIXES
+~~~~~~~~~
+
+
+1.4.1
+
+IMPROVEMENTS
+~~~~~~~~~~~~
+
* Add support for Python 3.9
(Thomas Grainger)
@@ -17,12 +26,27 @@ IMPROVEMENTS
* Drop support for Python 2.7, 3.4, and 3.5
(Stephen Finucane)
+* Convert python scripts to entry_points.
+ (Matthew Treinish)
+
+* Migrate CI from travis to GitHub actions.
+ (Matthew Treinish)
+
+* Add options to output filter to set timestamps.
+ (Matthew Treinish)
+
+* Remove dependency on unittest2.
+ (Matěj Cepl)
+
BUGFIXES
~~~~~~~~
* Fix tests with testtools >= 2.5.0.
(Colin Watson)
+* Mark rawstrings as such, fixing warnings.
+ (Stephen Finucane)
+
1.4.0
-----
diff --git a/configure.ac b/configure.ac
index 398ea58..ee4fdd4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
m4_define([SUBUNIT_MAJOR_VERSION], [1])
m4_define([SUBUNIT_MINOR_VERSION], [4])
-m4_define([SUBUNIT_MICRO_VERSION], [0])
+m4_define([SUBUNIT_MICRO_VERSION], [1])
m4_define([SUBUNIT_VERSION],
m4_defn([SUBUNIT_MAJOR_VERSION]).m4_defn([SUBUNIT_MINOR_VERSION]).m4_defn([SUBUNIT_MICRO_VERSION]))
AC_PREREQ([2.59])
diff --git a/python/subunit/__init__.py b/python/subunit/__init__.py
index 9d8bc7c..55b0e43 100644
--- a/python/subunit/__init__.py
+++ b/python/subunit/__init__.py
@@ -151,7 +151,7 @@ from subunit.v2 import ByteStreamToStreamResult, StreamResultToBytes
# If the releaselevel is 'final', then the tarball will be major.minor.micro.
# Otherwise it is major.minor.micro~$(revno).
-__version__ = (1, 4, 0, 'final', 0)
+__version__ = (1, 4, 1, 'final', 0)
PROGRESS_SET = 0
PROGRESS_CUR = 1