summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2022-11-05 21:38:24 +0000
committerJelmer Vernooij <jelmer@jelmer.uk>2022-11-05 21:38:24 +0000
commit5169aa4140707681030eec1f9f4c67e36bfdbbd5 (patch)
treeb7507862154a705885fba0c365803b4052b78328
parenta611e023ae9a0c269d556909306c77aa2b6b192a (diff)
downloadsubunit-git-5169aa4140707681030eec1f9f4c67e36bfdbbd5.tar.gz
fix perl distcheck
-rw-r--r--.gitignore1
-rw-r--r--Makefile.am13
-rw-r--r--configure.ac2
3 files changed, 7 insertions, 9 deletions
diff --git a/.gitignore b/.gitignore
index 30f733a..e565b8b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -54,3 +54,4 @@ perl/MYMETA.yml
*~
.*.swp
.*.swo
+perl/MYMETA.json
diff --git a/Makefile.am b/Makefile.am
index 629a7c7..e1cb02d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -122,16 +122,16 @@ clean-local:
rm -f perl/Makefile
# The default for MakeMaker; can be overridden by exporting
-INSTALLDIRS ?= site
+PERL_INSTALLDIRS ?= site
# Remove perl dir for VPATH builds.
distclean-local:
- -rm perl/Makefile.PL > /dev/null
+ -rm perl/Makefile.PL || true
-rmdir perl > /dev/null
-rm -r .hypothesis > /dev/null
install-exec-local: perl/Makefile
- $(MAKE) -C perl install INSTALLDIRS=${INSTALLDIRS}
+ $(MAKE) -C perl install INSTALLDIRS=${PERL_INSTALLDIRS} DESTDIR=$(DESTDIR) INSTALL_BASE=$(prefix) INSTALLSITEBIN=$(bindir)
mostlyclean-local:
rm -rf perl/blib
@@ -139,9 +139,4 @@ mostlyclean-local:
# 'uninstall' perl files during distcheck
uninstall-local: perl/Makefile
- $(MAKE) -C perl uninstall_distcheck INSTALLDIRS=${INSTALLDIRS}
-
-perl/Makefile: perl/Makefile.PL
- mkdir -p perl
- cd perl && perl Makefile.PL INSTALLDIRS=${INSTALLDIRS} PREFIX=
- -rm perl/Makefile.old > /dev/null
+ $(MAKE) -C perl uninstall_distcheck INSTALLDIRS=${PERL_INSTALLDIRS} DESTDIR=$(DESTDIR) INSTALLSITEBIN=$(bindir)
diff --git a/configure.ac b/configure.ac
index b5a59ee..398ea58 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,6 +68,8 @@ PKG_CHECK_MODULES([CPPUNIT], [cppunit])
# Output files
AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_COMMANDS([perl], [cd perl && perl Makefile.PL && cd ..], [])
+
AC_CONFIG_FILES([libsubunit.pc
libcppunit_subunit.pc
Makefile