summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2022-11-05 20:53:35 +0000
committerJelmer Vernooij <jelmer@jelmer.uk>2022-11-05 20:53:35 +0000
commita611e023ae9a0c269d556909306c77aa2b6b192a (patch)
treebd3ece206841726f9273442a779d652c5d3f9a44
parenta44fa88ac8b06828728fe9e772a5b140e73d93f7 (diff)
downloadsubunit-git-a611e023ae9a0c269d556909306c77aa2b6b192a.tar.gz
Fix distcheck; include python files again.
-rw-r--r--Makefile.am69
-rwxr-xr-xperl/Makefile.PL.in3
-rw-r--r--python/subunit/tests/test_subunit_filter.py2
3 files changed, 61 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index eb01f40..629a7c7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,6 +16,44 @@ EXTRA_DIST = \
perl/lib/Subunit.pm \
perl/lib/Subunit/Diff.pm \
perl/subunit-diff \
+ python/iso8601/LICENSE \
+ python/iso8601/README \
+ python/iso8601/README.subunit \
+ python/iso8601/setup.py \
+ python/iso8601/test_iso8601.py \
+ python/subunit/tests/__init__.py \
+ python/subunit/tests/sample-script.py \
+ python/subunit/tests/sample-two-script.py \
+ python/subunit/tests/test_chunked.py \
+ python/subunit/tests/test_details.py \
+ python/subunit/tests/test_filters.py \
+ python/subunit/tests/test_filter_to_disk.py \
+ python/subunit/tests/test_output_filter.py \
+ python/subunit/tests/test_progress_model.py \
+ python/subunit/tests/test_run.py \
+ python/subunit/tests/test_subunit_filter.py \
+ python/subunit/tests/test_subunit_stats.py \
+ python/subunit/tests/test_subunit_tags.py \
+ python/subunit/tests/test_tap2subunit.py \
+ python/subunit/tests/test_test_protocol.py \
+ python/subunit/tests/test_test_protocol2.py \
+ python/subunit/tests/test_test_results.py \
+ python/subunit/filter_scripts/__init__.py \
+ python/subunit/filter_scripts/subunit_1to2.py \
+ python/subunit/filter_scripts/subunit2csv.py \
+ python/subunit/filter_scripts/subunit2disk.py \
+ python/subunit/filter_scripts/subunit2gtk.py \
+ python/subunit/filter_scripts/subunit2junitxml.py \
+ python/subunit/filter_scripts/subunit2pyunit.py \
+ python/subunit/filter_scripts/subunit_2to1.py \
+ python/subunit/filter_scripts/subunit_filter.py \
+ python/subunit/filter_scripts/subunit_ls.py \
+ python/subunit/filter_scripts/subunit_notify.py \
+ python/subunit/filter_scripts/subunit_output.py \
+ python/subunit/filter_scripts/subunit_stats.py \
+ python/subunit/filter_scripts/subunit_tags.py \
+ python/subunit/filter_scripts/tap2subunit.py \
+ setup.py \
shell/README \
shell/share/subunit.sh \
shell/subunit-ui.patch \
@@ -34,6 +72,19 @@ pcdata_DATA = \
libsubunit.pc \
libcppunit_subunit.pc
+pkgpython_PYTHON = \
+ python/subunit/__init__.py \
+ python/subunit/chunked.py \
+ python/subunit/details.py \
+ python/subunit/filters.py \
+ python/subunit/iso8601.py \
+ python/subunit/progress_model.py \
+ python/subunit/run.py \
+ python/subunit/v2.py \
+ python/subunit/test_results.py \
+ python/subunit/_output.py \
+ python/subunit/_to_disk.py
+
lib_LTLIBRARIES = libsubunit.la
lib_LTLIBRARIES += libcppunit_subunit.la
@@ -63,36 +114,32 @@ all-local: perl/Makefile
check-local: perl/Makefile
$(MAKE) -C perl check
SHELL_SHARE='$(top_srcdir)/shell/share/' \
- PYTHONPATH='$(abs_top_srcdir)/python':'$(abs_top_srcdir)':${PYTHONPATH} \
+ PYTHONPATH='$(abs_top_srcdir)/python':'$(abs_top_srcdir)':$${PYTHONPATH} \
$(PYTHON) -m testtools.run all_tests.test_suite
clean-local:
find . -type f -name "*.pyc" -exec rm {} ';'
rm -f perl/Makefile
+# The default for MakeMaker; can be overridden by exporting
+INSTALLDIRS ?= site
+
# Remove perl dir for VPATH builds.
distclean-local:
-rm perl/Makefile.PL > /dev/null
- -rm perl/MYMETA.json > /dev/null
-rmdir perl > /dev/null
-rm -r .hypothesis > /dev/null
install-exec-local: perl/Makefile
- $(MAKE) -C perl install
+ $(MAKE) -C perl install INSTALLDIRS=${INSTALLDIRS}
mostlyclean-local:
rm -rf perl/blib
rm -rf perl/pm_to_blib
# 'uninstall' perl files during distcheck
-uninstall-local:
- if [ "_inst" = `basename ${prefix}` ]; then \
- $(MAKE) -C perl uninstall_distcheck; \
- rm -f "$(DESTDIR)$(bindir)"/subunit-diff; \
- fi
-
-# The default for MakeMaker; can be overridden by exporting
-INSTALLDIRS ?= site
+uninstall-local: perl/Makefile
+ $(MAKE) -C perl uninstall_distcheck INSTALLDIRS=${INSTALLDIRS}
perl/Makefile: perl/Makefile.PL
mkdir -p perl
diff --git a/perl/Makefile.PL.in b/perl/Makefile.PL.in
index 90a6a5e..395116e 100755
--- a/perl/Makefile.PL.in
+++ b/perl/Makefile.PL.in
@@ -13,7 +13,8 @@ check: # test
uninstall_distcheck:
find $(DESTDIR)$(INSTALLSITEARCH) -type f -exec rm {} \;
- rm MYMETA.yml
+ rm -f MYMETA.yml MYMETA.json
+ rm -f $(DESTINSTALLBIN)/subunit-diff
VPATH = @srcdir@
.PHONY: uninstall_distcheck
diff --git a/python/subunit/tests/test_subunit_filter.py b/python/subunit/tests/test_subunit_filter.py
index d14415a..3ae2a08 100644
--- a/python/subunit/tests/test_subunit_filter.py
+++ b/python/subunit/tests/test_subunit_filter.py
@@ -301,7 +301,7 @@ xfail todo
class TestFilterCommand(TestCase):
def run_command(self, args, stream):
- command = ['subunit-filter'] + list(args)
+ command = [sys.executable, '-m', 'subunit.filter_scripts.subunit_filter'] + list(args)
ps = subprocess.Popen(
command, stdin=subprocess.PIPE, stdout=subprocess.PIPE,
stderr=subprocess.PIPE)