summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormike bayer <mike_mp@zzzcomputing.com>2016-06-16 11:53:18 -0400
committerGerrit Code Review <gerrit2@ln3.zzzcomputing.com>2016-06-16 11:53:18 -0400
commitd8da8e4e7dd6b74165b78e6123ecdb3b18ca9bb3 (patch)
treeb29458b67e4cb43b1b95b7afda57d79beb2a4735
parente5bdf96bc0b1503c4e4c8461748cd061f624e346 (diff)
parent42078107f160d52e358db309d54c966440cc8a26 (diff)
downloadsqlalchemy-d8da8e4e7dd6b74165b78e6123ecdb3b18ca9bb3.tar.gz
Merge "update pytest good practices link in PyTest class"
-rw-r--r--setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 7fe61a4aa..2f5c3178c 100644
--- a/setup.py
+++ b/setup.py
@@ -75,8 +75,10 @@ class Distribution(_Distribution):
class PyTest(TestCommand):
- # from https://pytest.org/latest/goodpractises.html\
- # #integration-with-setuptools-test-commands
+ # from http://pytest.org/latest/goodpractices.html\
+ # #integrating-with-setuptools-python-setup-py-test-pytest-runner
+ # TODO: prefer pytest-runner package at some point, however it was
+ # not working at the time of this comment.
user_options = [('pytest-args=', 'a', "Arguments to pass to py.test")]
default_options = ["-n", "4", "-q"]