summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorshimizukawa <shimizukawa@gmail.com>2014-03-21 10:58:41 +0900
committershimizukawa <shimizukawa@gmail.com>2014-03-21 10:58:41 +0900
commit27f359a1a3e20f00229644a7a76553d1887ae1bd (patch)
treef46f245e4163fe0eb69621a257eebd2f8ee81e28 /setup.py
parent2d297818c560eb93823cc6eb6a808107c72db898 (diff)
downloadsphinx-27f359a1a3e20f00229644a7a76553d1887ae1bd.tar.gz
Fix: Generated i18n sphinx.js files are missing message catalog entries from '.js_t' and '.html'. The issue was introduced from Sphinx-1.1. Closes #1419
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 876c0782..d35c886f 100644
--- a/setup.py
+++ b/setup.py
@@ -136,7 +136,7 @@ else:
jscatalog = {}
for message in catalog:
- if any(x[0].endswith('.js') for x in message.locations):
+ if any(x[0].endswith(('.js', '.js_t', '.html')) for x in message.locations):
msgid = message.id
if isinstance(msgid, (list, tuple)):
msgid = msgid[0]