summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYu-Jie Lin <livibetter@gmail.com>2014-05-19 15:45:47 +0800
committerYu-Jie Lin <livibetter@gmail.com>2014-05-19 15:45:47 +0800
commitb367b0a6cf1bfa5ea7a95e0ae266b25f118f1630 (patch)
tree73fcd8a5ebb58492388986eb7208a53cba630ceb
parentfb07520a2dcb63daa7588b94207b1f7a3c08f0c1 (diff)
downloadsmartypants-git-b367b0a6cf1bfa5ea7a95e0ae266b25f118f1630.tar.gz
add test_doc8 target
-rw-r--r--CHANGES.rst1
-rw-r--r--Makefile6
-rw-r--r--docs/development.rst3
3 files changed, 8 insertions, 2 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index 65782ff..123c096 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -60,6 +60,7 @@ Development
+ add missing ``COPYING`` and ``CHANGES.rst`` to package (#3)
+ add ``bdist_wheel`` to the building process for Python Wheel format
++ add ``test_doc8`` target
Release 1.8.3: 2013-11-08T03:03:43Z
-----------------------------------
diff --git a/Makefile b/Makefile
index 9ca2522..ff41868 100644
--- a/Makefile
+++ b/Makefile
@@ -54,7 +54,7 @@ smartypants_command.py: smartypants
# ============================================================================
-test: test_isort test_pep8 test_pyflakes test_test install_test
+test: test_isort test_doc8 test_pep8 test_pyflakes test_test install_test
test_%:
@echo '========================================================================================='
@@ -62,6 +62,10 @@ test_%:
@echo '-----------------------------------------------------------------------------------------'
$(PY3_CMD) setup.py $(subst test_,,$@)
+test_doc8:
+ @echo '========================================================================================='
+ doc8 $(filter %.rst,$(DOC_FILES))
+
install_test: $(VENV_PY2_CMD) $(VENV_PY3_CMD)
$(VENV_PY2_CMD) $(VENV_PY3_CMD):
diff --git a/docs/development.rst b/docs/development.rst
index 7becb8d..8188fde 100644
--- a/docs/development.rst
+++ b/docs/development.rst
@@ -24,9 +24,10 @@ be able to run all tests with::
make test
-It will test PEP8, pyflakes, unittest, and package installation::
+It will test DOC8, PEP8, pyflakes, unittest, and package installation::
make test_isort
+ make test_doc8
make test_pep8
make test_pyflakes
make test_test