summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYu-Jie Lin <livibetter@gmail.com>2014-02-23 08:07:34 +0800
committerYu-Jie Lin <livibetter@gmail.com>2014-02-23 08:07:34 +0800
commitfb07520a2dcb63daa7588b94207b1f7a3c08f0c1 (patch)
treea88522296446cd49c4447c9262697fc515ba19fe
parenta8e64bcebb78c12770b2ae7819a76b40e110fb81 (diff)
downloadsmartypants-git-fb07520a2dcb63daa7588b94207b1f7a3c08f0c1.tar.gz
add Python Wheel to building process
-rw-r--r--CHANGES.rst3
-rw-r--r--Makefile2
-rw-r--r--setup.cfg3
-rwxr-xr-xsetup.py3
4 files changed, 9 insertions, 2 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index 8d85a25..65782ff 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -58,7 +58,8 @@ Release 2.0.0
Development
-----------
-- add missing ``COPYING`` and ``CHANGES.rst`` to package (#3)
++ add missing ``COPYING`` and ``CHANGES.rst`` to package (#3)
++ add ``bdist_wheel`` to the building process for Python Wheel format
Release 1.8.3: 2013-11-08T03:03:43Z
-----------------------------------
diff --git a/Makefile b/Makefile
index cdd8ed7..9ca2522 100644
--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,7 @@ INSTALL_TEST_DIR=/tmp/$(PACKAGE)_install_test
VENV_PY2_CMD=virtualenv-python2.7
VENV_PY3_CMD=virtualenv-python3.2
-BUILD_CMD=./setup.py sdist --formats gztar,zip bdist_wininst --plat-name win32
+BUILD_CMD=./setup.py sdist --formats gztar,zip bdist_wheel bdist_wininst --plat-name win32
DOC_FILES = CHANGES.rst COPYING docs/conf.py $(wildcard docs/*.rst)
diff --git a/setup.cfg b/setup.cfg
index 7389055..c212006 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -5,3 +5,6 @@ all_files = 1
[upload_sphinx]
upload-dir = docs/_build/html
+
+[wheel]
+universal = 1
diff --git a/setup.py b/setup.py
index 3970f0c..f623886 100755
--- a/setup.py
+++ b/setup.py
@@ -8,6 +8,8 @@ import sys
from distutils.core import Command, setup
from unittest import TestLoader, TextTestRunner
+from wheel.bdist_wheel import bdist_wheel
+
try:
from sphinx.setup_command import BuildDoc
except ImportError:
@@ -282,6 +284,7 @@ setup_d = dict(
name=module_name,
long_description=long_description,
cmdclass={
+ 'bdist_wheel': bdist_wheel,
'isort': cmd_isort,
'pep8': cmd_pep8,
'pyflakes': cmd_pyflakes,