summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYu-Jie Lin <livibetter@gmail.com>2014-07-20 17:14:54 +0800
committerYu-Jie Lin <livibetter@gmail.com>2014-07-20 17:14:54 +0800
commit431d4dd9bde33c3980ebadf6dc4a0f9756f58ced (patch)
tree3c27c79bc87cc42db9e74edd199eb4cf50e3e596
parent163174967fc1289cad5930aa55bcf1d0570c4aee (diff)
downloadsmartypants-git-431d4dd9bde33c3980ebadf6dc4a0f9756f58ced.tar.gz
test packages build in test_setup
The commit 95649d8b8795 was made to fix the mbcs bug in distutils, which was only discovered during the `make upload` when various packages were built to be uploaded. Testing packages build in virtualenv should avoid this type of situation ever occurring.
-rw-r--r--CHANGES.rst1
-rw-r--r--Makefile1
2 files changed, 2 insertions, 0 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index c22f9e0..3042a92 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -60,6 +60,7 @@ Development
* Makefile
+ + test packages build in ``test_setup`` target
* rename target ``install_test`` to ``test_setup``
diff --git a/Makefile b/Makefile
index 3fa142e..7b43989 100644
--- a/Makefile
+++ b/Makefile
@@ -77,6 +77,7 @@ test_setup_py2 test_setup_py3:
)
$(PY_CMD) -m virtualenv $(INSTALL_TEST_DIR)
LC_ALL=C $(PY_CMD) setup.py --version >/dev/null
+ $(PY_CMD) $(BUILD_CMD)
$(PY_CMD) setup.py sdist --dist-dir $(INSTALL_TEST_DIR)
$(INSTALL_TEST_DIR)/bin/pip install $(INSTALL_TEST_DIR)/*.tar.gz
@\