summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYu-Jie Lin <livibetter@gmail.com>2014-07-20 17:07:48 +0800
committerYu-Jie Lin <livibetter@gmail.com>2014-07-20 17:07:48 +0800
commit163174967fc1289cad5930aa55bcf1d0570c4aee (patch)
treed1ad448be07c1aff8e634e0bfdd4aeee2b923750
parent7cee2b42237f3f3630cfb04a2ec06ba174c3ddb3 (diff)
downloadsmartypants-git-163174967fc1289cad5930aa55bcf1d0570c4aee.tar.gz
rename target install_test to test_setup
-rw-r--r--CHANGES.rst5
-rw-r--r--Makefile8
-rw-r--r--docs/development.rst2
3 files changed, 10 insertions, 5 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index f440f9d..c22f9e0 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -58,6 +58,11 @@ Release 2.0.0
Development
-----------
+* Makefile
+
+ * rename target ``install_test`` to ``test_setup``
+
+
Release 1.8.6: 2014-07-19T11:20:52Z
-----------------------------------
diff --git a/Makefile b/Makefile
index 42e53cd..3fa142e 100644
--- a/Makefile
+++ b/Makefile
@@ -49,7 +49,7 @@ smartypants_command.py: smartypants
# ============================================================================
-test: test_isort test_doc8 test_pep8 test_pyflakes test_test install_test
+test: test_isort test_doc8 test_pep8 test_pyflakes test_test test_setup
test_%:
@echo '========================================================================================='
@@ -61,9 +61,9 @@ test_doc8:
@echo '========================================================================================='
doc8 $(filter %.rst,$(DOC_FILES))
-install_test: install_test_py2 install_test_py3
+test_setup: test_setup_py2 test_setup_py3
-install_test_py2 install_test_py3:
+test_setup_py2 test_setup_py3:
@echo '========================================================================================='
rm -rf $(INSTALL_TEST_DIR)
$(eval PY_CMD = \
@@ -97,4 +97,4 @@ clean:
# ============================================================================
-.PHONY: build upload doc install_test install_test_py2 install_test_py3 clean
+.PHONY: build upload doc test_setup test_setup_py2 test_setup_py3 clean
diff --git a/docs/development.rst b/docs/development.rst
index 8188fde..8a1893e 100644
--- a/docs/development.rst
+++ b/docs/development.rst
@@ -31,7 +31,7 @@ It will test DOC8, PEP8, pyflakes, unittest, and package installation::
make test_pep8
make test_pyflakes
make test_test
- make install_test
+ make test_setup
.. note:: They will all be tested with both Python 2 and Python 3. You may need
to override ``PY2_CMD`` and/or ``PY3_CMD``.