summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVille Skyttä <ville.skytta@iki.fi>2018-08-13 07:23:49 +0300
committerDB Tsai <dbtsai@dbtsai.com>2018-08-12 21:23:49 -0700
commit30a7cf100f4fe1dcbf03a06a760607fe5fd3c73d (patch)
treea368adb3dd5941b84bd834b3a537472add908dc9
parent9a758d1a68ebdb71111dc244acd0a4be42e6bdc8 (diff)
downloadpython-mimeparse-30a7cf100f4fe1dcbf03a06a760607fe5fd3c73d.tar.gz
Test updates and fixes (#33)
* Add Python 3.6 and 3.7 to test matrix * Flake8 whitespace fixes * Use pypy3.5-5.8.0 on Travis pypy3 in a python 2.7 env is no longer there.
-rw-r--r--.travis.yml9
-rwxr-xr-xsetup.py2
-rw-r--r--tox.ini8
3 files changed, 17 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index cda7cc9..d1f56cb 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -6,7 +6,6 @@ python:
env:
- TOXENV=py27
- TOXENV=py34
- - TOXENV=pypy3
- TOXENV=flake8
# https://github.com/travis-ci/travis-ci/issues/4794
@@ -14,8 +13,16 @@ matrix:
include:
- python: pypy-5.4
env: TOXENV=pypy
+ - python: pypy3.5-5.8.0
+ env: TOXENV=pypy3
- python: 3.5
env: TOXENV=py35
+ - python: 3.6
+ env: TOXENV=py36
+ - python: 3.7
+ env: TOXENV=py37
+ dist: xenial
+ sudo: true
# command to install dependencies
install:
diff --git a/setup.py b/setup.py
index cc081a0..50a8aa8 100755
--- a/setup.py
+++ b/setup.py
@@ -3,6 +3,7 @@
import codecs
import os
import re
+
from setuptools import setup
@@ -14,6 +15,7 @@ def get_version(filename):
contents = fp.read()
return re.search("__version__ = ['\"]([^'\"]+)['\"]", contents).group(1)
+
version = get_version('mimeparse.py')
if not version:
raise RuntimeError('Cannot find version information')
diff --git a/tox.ini b/tox.ini
index efdf5ff..97c4794 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,10 +1,16 @@
[tox]
-envlist = py35,py34,py32,py27,pypy,pypy3,flake8
+envlist = py37,py36,py35,py34,py32,py27,pypy,pypy3,flake8
[testenv]
commands = python --version
./mimeparse_test.py
+[testenv:py37]
+basepython = python3.7
+
+[testenv:py36]
+basepython = python3.6
+
[testenv:py35]
basepython = python3.5