summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2021-02-11 22:17:18 -0500
committerJason R. Coombs <jaraco@jaraco.com>2021-02-11 22:17:18 -0500
commitfd08292bf0ef33cfc9d96e91ddc88426f54eb521 (patch)
treeaf4b0456a7505876580d81d0a96716ce931ce7f6
parentea86b0d26872042737c1fea74eddebe0b6cbf207 (diff)
parent51298a2cc4faa7253e9fe41d7a9574cf9aac997c (diff)
downloadpytest-runner-fd08292bf0ef33cfc9d96e91ddc88426f54eb521.tar.gz
Merge https://github.com/jaraco/skeleton
-rw-r--r--.flake810
-rw-r--r--.github/workflows/main.yml2
-rw-r--r--.pre-commit-config.yaml4
-rw-r--r--README.rst6
-rw-r--r--docs/index.rst4
-rw-r--r--pyproject.toml10
-rw-r--r--setup.cfg16
-rw-r--r--skeleton.md2
-rw-r--r--tox.ini4
9 files changed, 32 insertions, 26 deletions
diff --git a/.flake8 b/.flake8
index 790c109..48b2e24 100644
--- a/.flake8
+++ b/.flake8
@@ -1,9 +1,9 @@
[flake8]
max-line-length = 88
-ignore =
- # W503 violates spec https://github.com/PyCQA/pycodestyle/issues/513
- W503
- # W504 has issues https://github.com/OCA/maintainer-quality-tools/issues/545
- W504
+
+# jaraco/skeleton#34
+max-complexity = 10
+
+extend-ignore =
# Black creates whitespace before colon
E203
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
index 8c5c232..6a8ff00 100644
--- a/.github/workflows/main.yml
+++ b/.github/workflows/main.yml
@@ -1,4 +1,4 @@
-name: Automated Tests
+name: tests
on: [push, pull_request]
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 6639c78..c15ab0c 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -1,10 +1,10 @@
repos:
- repo: https://github.com/psf/black
- rev: stable
+ rev: 20.8b1
hooks:
- id: black
- repo: https://github.com/asottile/blacken-docs
- rev: v1.8.0
+ rev: v1.9.1
hooks:
- id: blacken-docs
diff --git a/README.rst b/README.rst
index 274c4c3..9f700f4 100644
--- a/README.rst
+++ b/README.rst
@@ -6,9 +6,9 @@
.. _PyPI link: https://pypi.org/project/pytest-runner
-.. image:: https://github.com/jaraco/pytest-runner/workflows/Automated%20Tests/badge.svg
- :target: https://github.com/jaraco/pytest-runner/actions?query=workflow%3A%22Automated+Tests%22
- :alt: Automated Tests
+.. image:: https://github.com/jaraco/pytest-runner/workflows/tests/badge.svg
+ :target: https://github.com/jaraco/pytest-runner/actions?query=workflow%3A%22tests%22
+ :alt: tests
.. image:: https://img.shields.io/badge/code%20style-black-000000.svg
:target: https://github.com/psf/black
diff --git a/docs/index.rst b/docs/index.rst
index ae93273..c43329a 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -1,5 +1,5 @@
-Welcome to pytest-runner documentation!
-=======================================
+Welcome to |project| documentation!
+===================================
.. toctree::
:maxdepth: 1
diff --git a/pyproject.toml b/pyproject.toml
index 79f088a..b6ebc0b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -7,16 +7,14 @@ skip-string-normalization = true
[tool.setuptools_scm]
-# jaraco/skeleton#22
-[tool.jaraco.pytest.plugins.black]
+[pytest.enabler.black]
addopts = "--black"
-# jaraco/skeleton#22
-[tool.jaraco.pytest.plugins.mypy]
+[pytest.enabler.mypy]
addopts = "--mypy"
-[tool.jaraco.pytest.plugins.flake8]
+[pytest.enabler.flake8]
addopts = "--flake8"
-[tool.jaraco.pytest.plugins.cov]
+[pytest.enabler.cov]
addopts = "--cov"
diff --git a/setup.cfg b/setup.cfg
index 81ddc6e..4b1f33d 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,6 @@
[metadata]
-license_file = LICENSE
+license_files =
+ LICENSE
name = pytest-runner
author = Jason R. Coombs
author_email = jaraco@jaraco.com
@@ -15,7 +16,7 @@ classifiers =
Framework :: Pytest
[options]
-packages = find:
+packages = find_namespace:
py_modules = ptr
include_package_data = true
python_requires = >=3.6
@@ -23,6 +24,12 @@ install_requires =
# setuptools 27.3 is required at run time
setup_requires = setuptools_scm[toml] >= 3.4.1
+[options.packages.find]
+exclude =
+ build*
+ docs*
+ tests*
+
[options.extras_require]
testing =
# upstream
@@ -32,8 +39,7 @@ testing =
pytest-black >= 0.3.7; python_implementation != "PyPy"
pytest-cov
pytest-mypy; python_implementation != "PyPy"
- # jaraco/skeleton#22
- jaraco.test >= 3.2.0
+ pytest-enabler
# local
pytest-virtualenv
@@ -41,7 +47,7 @@ testing =
docs =
# upstream
sphinx
- jaraco.packaging >= 3.2
+ jaraco.packaging >= 8.2
rst.linker >= 1.9
# local
diff --git a/skeleton.md b/skeleton.md
index dd8ec01..0938f89 100644
--- a/skeleton.md
+++ b/skeleton.md
@@ -138,6 +138,8 @@ Features include:
- test against multiple Python versions
- run on late (and updated) platform versions
- automated releases of tagged commits
+- [automatic merging of PRs](https://github.com/marketplace/actions/merge-pull-requests) (requires [protecting branches with required status checks](https://docs.github.com/en/free-pro-team@latest/github/administering-a-repository/enabling-required-status-checks), [not possible through API](https://github.community/t/set-all-status-checks-to-be-required-as-branch-protection-using-the-github-api/119493))
+
### Continuous Deployments
diff --git a/tox.ini b/tox.ini
index d624e65..f893aaa 100644
--- a/tox.ini
+++ b/tox.ini
@@ -24,7 +24,7 @@ commands =
[testenv:release]
skip_install = True
deps =
- pep517>=0.5
+ build
twine[keyring]>=1.13
path
jaraco.develop>=7.1
@@ -36,7 +36,7 @@ setenv =
TWINE_USERNAME = {env:TWINE_USERNAME:__token__}
commands =
python -c "import path; path.Path('dist').rmtree_p()"
- python -m pep517.build .
+ python -m build
python -m twine upload dist/*
python -m jaraco.develop.create-github-release
python -m jaraco.tidelift.publish-release-notes