summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2021-02-11 22:16:28 -0500
committerJason R. Coombs <jaraco@jaraco.com>2021-02-11 22:16:28 -0500
commitea86b0d26872042737c1fea74eddebe0b6cbf207 (patch)
tree3acc35378119e069d65c09ac0ed5e530856d8aa6
parent0880a9876cf424458b82757d1c7504be58f9c2c1 (diff)
parenta11446dc8ad2207306a0b58d61a6d404b56ecc4b (diff)
downloadpytest-runner-ea86b0d26872042737c1fea74eddebe0b6cbf207.tar.gz
Merge branch '2020-handoff' of https://github.com/jaraco/skeleton
-rw-r--r--.github/workflows/automerge.yml27
-rw-r--r--.github/workflows/main.yml42
-rw-r--r--.pre-commit-config.yaml9
-rw-r--r--.readthedocs.yml9
-rw-r--r--.travis.yml28
-rw-r--r--LICENSE18
-rw-r--r--README.rst19
-rw-r--r--appveyor.yml24
-rw-r--r--docs/conf.py2
-rw-r--r--mypy.ini2
-rw-r--r--pyproject.toml18
-rw-r--r--pytest.ini12
-rw-r--r--setup.cfg18
-rw-r--r--setup.py2
-rw-r--r--skeleton.md73
-rw-r--r--tox.ini23
16 files changed, 202 insertions, 124 deletions
diff --git a/.github/workflows/automerge.yml b/.github/workflows/automerge.yml
new file mode 100644
index 0000000..4f70acf
--- /dev/null
+++ b/.github/workflows/automerge.yml
@@ -0,0 +1,27 @@
+name: automerge
+on:
+ pull_request:
+ types:
+ - labeled
+ - unlabeled
+ - synchronize
+ - opened
+ - edited
+ - ready_for_review
+ - reopened
+ - unlocked
+ pull_request_review:
+ types:
+ - submitted
+ check_suite:
+ types:
+ - completed
+ status: {}
+jobs:
+ automerge:
+ runs-on: ubuntu-latest
+ steps:
+ - name: automerge
+ uses: "pascalgn/automerge-action@v0.12.0"
+ env:
+ GITHUB_TOKEN: "${{ secrets.GITHUB_TOKEN }}"
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
new file mode 100644
index 0000000..8c5c232
--- /dev/null
+++ b/.github/workflows/main.yml
@@ -0,0 +1,42 @@
+name: Automated Tests
+
+on: [push, pull_request]
+
+jobs:
+ test:
+ strategy:
+ matrix:
+ python: [3.6, 3.8, 3.9]
+ platform: [ubuntu-latest, macos-latest, windows-latest]
+ runs-on: ${{ matrix.platform }}
+ steps:
+ - uses: actions/checkout@v2
+ - name: Setup Python
+ uses: actions/setup-python@v2
+ with:
+ python-version: ${{ matrix.python }}
+ - name: Install tox
+ run: |
+ python -m pip install tox
+ - name: Run tests
+ run: tox
+
+ release:
+ needs: test
+ if: github.event_name == 'push' && contains(github.ref, 'refs/tags/')
+ runs-on: ubuntu-latest
+
+ steps:
+ - uses: actions/checkout@v2
+ - name: Setup Python
+ uses: actions/setup-python@v2
+ with:
+ python-version: 3.9
+ - name: Install tox
+ run: |
+ python -m pip install tox
+ - name: Release
+ run: tox -e release
+ env:
+ TWINE_PASSWORD: ${{ secrets.PYPI_TOKEN }}
+ GITHUB_TOKEN: ${{ secrets.GITHUB_TOKEN }}
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 922d942..6639c78 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -1,5 +1,10 @@
repos:
-- repo: https://github.com/ambv/black
- rev: 18.9b0
+- repo: https://github.com/psf/black
+ rev: stable
hooks:
- id: black
+
+- repo: https://github.com/asottile/blacken-docs
+ rev: v1.8.0
+ hooks:
+ - id: blacken-docs
diff --git a/.readthedocs.yml b/.readthedocs.yml
index 8ae4468..cc69854 100644
--- a/.readthedocs.yml
+++ b/.readthedocs.yml
@@ -1,5 +1,6 @@
+version: 2
python:
- version: 3
- extra_requirements:
- - docs
- pip_install: true
+ install:
+ - path: .
+ extra_requirements:
+ - docs
diff --git a/.travis.yml b/.travis.yml
deleted file mode 100644
index 6ccac8f..0000000
--- a/.travis.yml
+++ /dev/null
@@ -1,28 +0,0 @@
-dist: xenial
-language: python
-
-python:
-- 2.7
-- 3.6
-- &latest_py3 3.7
-
-jobs:
- fast_finish: true
- include:
- - stage: deploy
- if: tag IS present
- python: *latest_py3
- before_script: skip
- script: tox -e release
-
-cache: pip
-
-install:
-- pip install tox tox-venv
-
-before_script:
- # Disable IPv6. Ref travis-ci/travis-ci#8361
- - if [ "${TRAVIS_OS_NAME}" == "linux" ]; then
- sudo sh -c 'echo 0 > /proc/sys/net/ipv6/conf/all/disable_ipv6';
- fi
-script: tox
diff --git a/LICENSE b/LICENSE
index 5e795a6..353924b 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,7 +1,19 @@
Copyright Jason R. Coombs
-Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to
+deal in the Software without restriction, including without limitation the
+rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
+sell copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
-The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+IN THE SOFTWARE.
diff --git a/README.rst b/README.rst
index ba9805b..274c4c3 100644
--- a/README.rst
+++ b/README.rst
@@ -1,20 +1,21 @@
.. image:: https://img.shields.io/pypi/v/pytest-runner.svg
- :target: https://pypi.org/project/pytest-runner
+ :target: `PyPI link`_
.. image:: https://img.shields.io/pypi/pyversions/pytest-runner.svg
+ :target: `PyPI link`_
-.. image:: https://img.shields.io/travis/pytest-dev/pytest-runner/master.svg
- :target: https://travis-ci.org/pytest-dev/pytest-runner
+.. _PyPI link: https://pypi.org/project/pytest-runner
+
+.. image:: https://github.com/jaraco/pytest-runner/workflows/Automated%20Tests/badge.svg
+ :target: https://github.com/jaraco/pytest-runner/actions?query=workflow%3A%22Automated+Tests%22
+ :alt: Automated Tests
.. image:: https://img.shields.io/badge/code%20style-black-000000.svg
- :target: https://github.com/ambv/black
+ :target: https://github.com/psf/black
:alt: Code style: Black
-.. .. image:: https://img.shields.io/appveyor/ci/pytest-dev/pytest-runner/master.svg
-.. :target: https://ci.appveyor.com/project/pytest-dev/pytest-runner/branch/master
-
-.. .. image:: https://readthedocs.org/projects/pytest-runner/badge/?version=latest
-.. :target: https://pytest-runner.readthedocs.io/en/latest/?badge=latest
+.. .. image:: https://readthedocs.org/projects/skeleton/badge/?version=latest
+.. :target: https://skeleton.readthedocs.io/en/latest/?badge=latest
.. image:: https://tidelift.com/badges/package/pypi/pytest-runner
:target: https://tidelift.com/subscription/pkg/pypi-pytest-runner?utm_source=pypi-pytest-runner&utm_medium=readme
diff --git a/appveyor.yml b/appveyor.yml
deleted file mode 100644
index f35aa27..0000000
--- a/appveyor.yml
+++ /dev/null
@@ -1,24 +0,0 @@
-environment:
-
- APPVEYOR: true
-
- matrix:
- - PYTHON: "C:\\Python36-x64"
- - PYTHON: "C:\\Python27-x64"
-
-install:
- # symlink python from a directory with a space
- - "mklink /d \"C:\\Program Files\\Python\" %PYTHON%"
- - "SET PYTHON=\"C:\\Program Files\\Python\""
- - "SET PATH=%PYTHON%;%PYTHON%\\Scripts;%PATH%"
-
-build: off
-
-cache:
- - '%LOCALAPPDATA%\pip\Cache'
-
-test_script:
- - "python -m pip install -U tox tox-venv virtualenv"
- - "tox"
-
-version: '{build}'
diff --git a/docs/conf.py b/docs/conf.py
index e06bee4..509290a 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -14,7 +14,7 @@ link_files = {
url='{package_url}/issues/{issue}',
),
dict(
- pattern=r'^(?m)((?P<scm_version>v?\d+(\.\d+){1,2}))\n[-=]+\n',
+ pattern=r'(?m:^((?P<scm_version>v?\d+(\.\d+){1,2}))\n[-=]+\n)',
with_scm='{text}\n{rev[timestamp]:%d %b %Y}\n',
),
dict(
diff --git a/mypy.ini b/mypy.ini
new file mode 100644
index 0000000..976ba02
--- /dev/null
+++ b/mypy.ini
@@ -0,0 +1,2 @@
+[mypy]
+ignore_missing_imports = True
diff --git a/pyproject.toml b/pyproject.toml
index 3afc8c3..79f088a 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,22 @@
[build-system]
-requires = ["setuptools>=34.4", "wheel", "setuptools_scm>=1.15"]
+requires = ["setuptools>=42", "wheel", "setuptools_scm[toml]>=3.4.1"]
build-backend = "setuptools.build_meta"
[tool.black]
skip-string-normalization = true
+
+[tool.setuptools_scm]
+
+# jaraco/skeleton#22
+[tool.jaraco.pytest.plugins.black]
+addopts = "--black"
+
+# jaraco/skeleton#22
+[tool.jaraco.pytest.plugins.mypy]
+addopts = "--mypy"
+
+[tool.jaraco.pytest.plugins.flake8]
+addopts = "--flake8"
+
+[tool.jaraco.pytest.plugins.cov]
+addopts = "--cov"
diff --git a/pytest.ini b/pytest.ini
index a86fb66..d7f0b11 100644
--- a/pytest.ini
+++ b/pytest.ini
@@ -1,11 +1,9 @@
[pytest]
norecursedirs=dist build .tox .eggs
-addopts=--doctest-modules --flake8 --black --cov
+addopts=--doctest-modules
doctest_optionflags=ALLOW_UNICODE ELLIPSIS
+# workaround for warning pytest-dev/pytest#6178
+junit_family=xunit2
filterwarnings=
- ignore:Possible nested set::pycodestyle:113
- ignore:Using or importing the ABCs::flake8:410
- # workaround for https://sourceforge.net/p/docutils/bugs/348/
- ignore:'U' mode is deprecated::docutils.io
- # workaround for https://gitlab.com/pycqa/flake8/issues/275
- ignore:You passed a bytestring as `filenames`.::flake8
+ # https://github.com/pytest-dev/pytest/issues/6928
+ ignore:direct construction of .*Item has been deprecated:DeprecationWarning
diff --git a/setup.cfg b/setup.cfg
index 931d36d..81ddc6e 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,3 @@
-[bdist_wheel]
-universal = 1
-
[metadata]
license_file = LICENSE
name = pytest-runner
@@ -13,25 +10,30 @@ classifiers =
Development Status :: 5 - Production/Stable
Intended Audience :: Developers
License :: OSI Approved :: MIT License
- Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
+ Programming Language :: Python :: 3 :: Only
Framework :: Pytest
[options]
+packages = find:
py_modules = ptr
-python_requires = >=2.7
+include_package_data = true
+python_requires = >=3.6
install_requires =
# setuptools 27.3 is required at run time
-setup_requires = setuptools_scm >= 1.15.0
+setup_requires = setuptools_scm[toml] >= 3.4.1
[options.extras_require]
testing =
# upstream
pytest >= 3.5, !=3.7.3
- pytest-checkdocs
+ pytest-checkdocs >= 1.2.3
pytest-flake8
- pytest-black-multipy
+ pytest-black >= 0.3.7; python_implementation != "PyPy"
pytest-cov
+ pytest-mypy; python_implementation != "PyPy"
+ # jaraco/skeleton#22
+ jaraco.test >= 3.2.0
# local
pytest-virtualenv
diff --git a/setup.py b/setup.py
index d6459a0..e58e686 100644
--- a/setup.py
+++ b/setup.py
@@ -18,4 +18,4 @@ added, supply the basic metadata here. Ref #49.
"""
if __name__ == "__main__":
- setuptools.setup(use_scm_version=True, **compat)
+ setuptools.setup(**compat)
diff --git a/skeleton.md b/skeleton.md
index 52b97f0..dd8ec01 100644
--- a/skeleton.md
+++ b/skeleton.md
@@ -2,9 +2,9 @@
This project is merged with [skeleton](https://github.com/jaraco/skeleton). What is skeleton? It's the scaffolding of a Python project jaraco [introduced in his blog](https://blog.jaraco.com/a-project-skeleton-for-python-projects/). It seeks to provide a means to re-use techniques and inherit advances when managing projects for distribution.
-## An SCM Managed Approach
+## An SCM-Managed Approach
-While maintaining dozens of projects in PyPI, jaraco derives best practices for project distribution and publishes them in the [skeleton repo](https://github.com/jaraco/skeleton), a git repo capturing the evolution and culmination of these best practices.
+While maintaining dozens of projects in PyPI, jaraco derives best practices for project distribution and publishes them in the [skeleton repo](https://github.com/jaraco/skeleton), a Git repo capturing the evolution and culmination of these best practices.
It's intended to be used by a new or existing project to adopt these practices and honed and proven techniques. Adopters are encouraged to use the project directly and maintain a small deviation from the technique, make their own fork for more substantial changes unique to their environment or preferences, or simply adopt the skeleton once and abandon it thereafter.
@@ -38,24 +38,49 @@ The `--allow-unrelated-histories` is necessary because the history from the skel
## Updating
-Whenever a change is needed or desired for the general technique for packaging, it can be made in the skeleton project and then merged into each of the derived projects as needed, recommended before each release. As a result, features and best practices for packaging are centrally maintained and readily trickle into a whole suite of packages. This technique lowers the amount of tedious work necessary to create or maintain a project, and coupled with other techniques like continuous integration and deployment, lowers the cost of creating and maintaining refined Python projects to just a few, familiar git operations.
+Whenever a change is needed or desired for the general technique for packaging, it can be made in the skeleton project and then merged into each of the derived projects as needed, recommended before each release. As a result, features and best practices for packaging are centrally maintained and readily trickle into a whole suite of packages. This technique lowers the amount of tedious work necessary to create or maintain a project, and coupled with other techniques like continuous integration and deployment, lowers the cost of creating and maintaining refined Python projects to just a few, familiar Git operations.
+
+For example, here's a session of the [path project](https://pypi.org/project/path) pulling non-conflicting changes from the skeleton:
+
+<img src="https://raw.githubusercontent.com/jaraco/skeleton/gh-pages/docs/refresh.svg">
Thereafter, the target project can make whatever customizations it deems relevant to the scaffolding. The project may even at some point decide that the divergence is too great to merit renewed merging with the original skeleton. This approach applies maximal guidance while creating minimal constraints.
+## Periodic Collapse
+
+In late 2020, this project [introduced](https://github.com/jaraco/skeleton/issues/27) the idea of a periodic but infrequent (O(years)) collapse of commits to limit the number of commits a new consumer will need to accept to adopt the skeleton.
+
+The full history of commits is collapsed into a single commit and that commit becomes the new mainline head.
+
+When one of these collapse operations happens, any project that previously pulled from the skeleton will no longer have a related history with that new main branch. For those projects, the skeleton provides a "handoff" branch that reconciles the two branches. Any project that has previously merged with the skeleton but now gets an error "fatal: refusing to merge unrelated histories" should instead use the handoff branch once to incorporate the new main branch.
+
+```
+$ git pull https://github.com/jaraco/skeleton 2020-handoff
+```
+
+This handoff needs to be pulled just once and thereafter the project can pull from the main head.
+
+The archive and handoff branches from prior collapses are indicate here:
+
+| refresh | archive | handoff |
+|---------|-----------------|--------------|
+| 2020-12 | archive/2020-12 | 2020-handoff |
+
# Features
The features/techniques employed by the skeleton include:
-- PEP 517/518 based build relying on setuptools as the build tool
-- setuptools declarative configuration using setup.cfg
+- PEP 517/518-based build relying on Setuptools as the build tool
+- Setuptools declarative configuration using setup.cfg
- tox for running tests
-- A README.rst as reStructuredText with some popular badges, but with readthedocs and appveyor badges commented out
+- A README.rst as reStructuredText with some popular badges, but with Read the Docs and AppVeyor badges commented out
- A CHANGES.rst file intended for publishing release notes about the project
-- Use of [black](https://black.readthedocs.io/en/stable/) for code formatting (disabled on unsupported Python 3.5 and earlier)
+- Use of [Black](https://black.readthedocs.io/en/stable/) for code formatting (disabled on unsupported Python 3.5 and earlier)
+- Integrated type checking through [mypy](https://github.com/python/mypy/).
## Packaging Conventions
-A pyproject.toml is included to enable PEP 517 and PEP 518 compatibility and declares the requirements necessary to build the project on setuptools (a minimum version compatible with setup.cfg declarative config).
+A pyproject.toml is included to enable PEP 517 and PEP 518 compatibility and declares the requirements necessary to build the project on Setuptools (a minimum version compatible with setup.cfg declarative config).
The setup.cfg file implements the following features:
@@ -85,46 +110,48 @@ The skeleton assumes the developer has [tox](https://pypi.org/project/tox) insta
Other environments (invoked with `tox -e {name}`) supplied include:
- - a `build-docs` environment to build the documentation
+ - a `docs` environment to build the documentation
- a `release` environment to publish the package to PyPI
A pytest.ini is included to define common options around running tests. In particular:
- rely on default test discovery in the current directory
- avoid recursing into common directories not containing tests
-- run doctests on modules and invoke flake8 tests
-- in doctests, allow unicode literals and regular literals to match, allowing for doctests to run on Python 2 and 3. Also enable ELLIPSES, a default that would be undone by supplying the prior option.
+- run doctests on modules and invoke Flake8 tests
+- in doctests, allow Unicode literals and regular literals to match, allowing for doctests to run on Python 2 and 3. Also enable ELLIPSES, a default that would be undone by supplying the prior option.
- filters out known warnings caused by libraries/functionality included by the skeleton
-Relies a .flake8 file to correct some default behaviors:
+Relies on a .flake8 file to correct some default behaviors:
- disable mutually incompatible rules W503 and W504
-- support for black format
+- support for Black format
## Continuous Integration
-The project is pre-configured to run tests in [Travis-CI](https://travis-ci.org) (.travis.yml). Any new project must be enabled either through their web site or with the `travis enable` command.
+The project is pre-configured to run Continuous Integration tests.
-Features include:
-- test against Python 2 and 3
-- run on Ubuntu Xenial
-- correct for broken IPv6
+### Github Actions
+
+[Github Actions](https://docs.github.com/en/free-pro-team@latest/actions) are the preferred provider as they provide free, fast, multi-platform services with straightforward configuration. Configured in `.github/workflows`.
-Also provided is a minimal template for running under Appveyor (Windows).
+Features include:
+- test against multiple Python versions
+- run on late (and updated) platform versions
+- automated releases of tagged commits
### Continuous Deployments
-In addition to running tests, an additional deploy stage is configured to automatically release tagged commits to PyPI using [API tokens](https://pypi.org/help/#apitoken). The release process expects an authorized token to be configured with Travis as the TWINE_PASSWORD environment variable. After the Travis project is created, configure the token through the web UI or with a command like the following (bash syntax):
+In addition to running tests, an additional publish stage is configured to automatically release tagged commits to PyPI using [API tokens](https://pypi.org/help/#apitoken). The release process expects an authorized token to be configured with each Github project (or org) `PYPI_TOKEN` [secret](https://docs.github.com/en/free-pro-team@latest/actions/reference/encrypted-secrets). Example:
```
-TWINE_PASSWORD={token} travis env copy TWINE_PASSWORD
+pip-run -q jaraco.develop -- -m jaraco.develop.add-github-secrets
```
## Building Documentation
-Documentation is automatically built by [Read the Docs](https://readthedocs.org) when the project is registered with it, by way of the .readthedocs.yml file. To test the docs build manually, a tox env may be invoked as `tox -e build-docs`. Both techniques rely on the dependencies declared in `setup.cfg/options.extras_require.docs`.
+Documentation is automatically built by [Read the Docs](https://readthedocs.org) when the project is registered with it, by way of the .readthedocs.yml file. To test the docs build manually, a tox env may be invoked as `tox -e docs`. Both techniques rely on the dependencies declared in `setup.cfg/options.extras_require.docs`.
-In addition to building the sphinx docs scaffolded in `docs/`, the docs build a `history.html` file that first injects release dates and hyperlinks into the CHANGES.rst before incorporating it as history in the docs.
+In addition to building the Sphinx docs scaffolded in `docs/`, the docs build a `history.html` file that first injects release dates and hyperlinks into the CHANGES.rst before incorporating it as history in the docs.
## Cutting releases
diff --git a/tox.ini b/tox.ini
index 2e22bd3..d624e65 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,38 +3,34 @@ envlist = python
minversion = 3.2
# https://github.com/jaraco/skeleton/issues/6
tox_pip_extensions_ext_venv_update = true
-# Ensure that a late version of pip is used even on tox-venv.
-requires =
- tox-pip-version>=0.0.6
- tox-venv
+toxworkdir={env:TOX_WORK_DIR:.tox}
[testenv]
deps =
- setuptools>=31.0.1
-pip_version = pip
commands =
pytest {posargs}
usedevelop = True
extras = testing
-[testenv:build-docs]
+[testenv:docs]
extras =
- docs
- testing
+ docs
+ testing
changedir = docs
commands =
- python -m sphinx . {toxinidir}/build/html
+ python -m sphinx . {toxinidir}/build/html
[testenv:release]
skip_install = True
deps =
pep517>=0.5
- twine>=1.13
- path.py
- jaraco.tidelift
+ twine[keyring]>=1.13
+ path
+ jaraco.develop>=7.1
passenv =
TWINE_PASSWORD
+ GITHUB_TOKEN
TIDELIFT_TOKEN
setenv =
TWINE_USERNAME = {env:TWINE_USERNAME:__token__}
@@ -42,4 +38,5 @@ commands =
python -c "import path; path.Path('dist').rmtree_p()"
python -m pep517.build .
python -m twine upload dist/*
+ python -m jaraco.develop.create-github-release
python -m jaraco.tidelift.publish-release-notes