summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2020-09-12 19:02:55 -0400
committerJason R. Coombs <jaraco@jaraco.com>2020-09-12 23:39:01 -0400
commit678e1a973a0139c0e0ab40395dfbada6c3ea72b9 (patch)
treea4b1d0b2434bcafa5d2d1a69fd9e1623e92c6db3
parent8117892ea5da9969f49756933bcbaa576ee7c5d7 (diff)
downloadpytest-runner-678e1a973a0139c0e0ab40395dfbada6c3ea72b9.tar.gz
Also enable flake8 and cov when the plugins are present.
-rw-r--r--pyproject.toml6
-rw-r--r--pytest.ini2
-rw-r--r--setup.cfg2
3 files changed, 8 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 9cd13ba..79f088a 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -14,3 +14,9 @@ addopts = "--black"
# jaraco/skeleton#22
[tool.jaraco.pytest.plugins.mypy]
addopts = "--mypy"
+
+[tool.jaraco.pytest.plugins.flake8]
+addopts = "--flake8"
+
+[tool.jaraco.pytest.plugins.cov]
+addopts = "--cov"
diff --git a/pytest.ini b/pytest.ini
index 5ffd7f7..d7f0b11 100644
--- a/pytest.ini
+++ b/pytest.ini
@@ -1,6 +1,6 @@
[pytest]
norecursedirs=dist build .tox .eggs
-addopts=--doctest-modules --flake8 --cov
+addopts=--doctest-modules
doctest_optionflags=ALLOW_UNICODE ELLIPSIS
# workaround for warning pytest-dev/pytest#6178
junit_family=xunit2
diff --git a/setup.cfg b/setup.cfg
index eb834fe..6321ca7 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -30,7 +30,7 @@ testing =
pytest-cov
pytest-mypy; python_implementation != "PyPy"
# jaraco/skeleton#22
- jaraco.test >= 3.1.1
+ jaraco.test >= 3.2.0
# local