summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2020-09-12 14:18:23 -0400
committerJason R. Coombs <jaraco@jaraco.com>2020-09-12 14:54:03 -0400
commit8117892ea5da9969f49756933bcbaa576ee7c5d7 (patch)
treeaa837ff59f19a07c9f4bbcadf3b3e6ddc91c4661
parent38207546aea22e38433a316c6ad9bf024de61ef3 (diff)
downloadpytest-runner-8117892ea5da9969f49756933bcbaa576ee7c5d7.tar.gz
Use enabled plugin configuration to enable mypy and black when the plugin is present. Ref jaraco/skeleton#22.
-rw-r--r--pyproject.toml8
-rw-r--r--pytest.ini2
-rw-r--r--setup.cfg2
3 files changed, 6 insertions, 6 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 9b02ee7..9cd13ba 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -8,9 +8,9 @@ skip-string-normalization = true
[tool.setuptools_scm]
# jaraco/skeleton#22
-[tool.jaraco.pytest.opts.--black]
-action = "store_true"
+[tool.jaraco.pytest.plugins.black]
+addopts = "--black"
# jaraco/skeleton#22
-[tool.jaraco.pytest.opts.--mypy]
-action = "store_true"
+[tool.jaraco.pytest.plugins.mypy]
+addopts = "--mypy"
diff --git a/pytest.ini b/pytest.ini
index 381b327..5ffd7f7 100644
--- a/pytest.ini
+++ b/pytest.ini
@@ -1,6 +1,6 @@
[pytest]
norecursedirs=dist build .tox .eggs
-addopts=--doctest-modules --flake8 --black --cov --mypy
+addopts=--doctest-modules --flake8 --cov
doctest_optionflags=ALLOW_UNICODE ELLIPSIS
# workaround for warning pytest-dev/pytest#6178
junit_family=xunit2
diff --git a/setup.cfg b/setup.cfg
index e9dd177..eb834fe 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -30,7 +30,7 @@ testing =
pytest-cov
pytest-mypy; python_implementation != "PyPy"
# jaraco/skeleton#22
- jaraco.test >= 3
+ jaraco.test >= 3.1.1
# local