summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2022-02-25 10:54:30 -0500
committerJason R. Coombs <jaraco@jaraco.com>2022-02-25 10:54:30 -0500
commit289a77b179535d8137118e3b8591d9e727130d6d (patch)
treec8b047950a96650f18e2f22fe2c85b8d0d623e54
parent3ae5a49054616e2c00a5ddcb26e870a5beababcf (diff)
parent04fe68a96ee8e3d3ca521b4abbfe53203063f9d9 (diff)
downloadpytest-runner-289a77b179535d8137118e3b8591d9e727130d6d.tar.gz
Merge https://github.com/jaraco/skeleton
-rw-r--r--.editorconfig1
-rw-r--r--.github/workflows/main.yml11
-rw-r--r--.pre-commit-config.yaml7
-rw-r--r--README.rst2
-rw-r--r--docs/conf.py7
-rw-r--r--pyproject.toml2
-rw-r--r--pytest.ini14
-rw-r--r--setup.cfg8
-rw-r--r--setup.py21
9 files changed, 32 insertions, 41 deletions
diff --git a/.editorconfig b/.editorconfig
index 6385b57..b8aeea1 100644
--- a/.editorconfig
+++ b/.editorconfig
@@ -9,6 +9,7 @@ end_of_line = lf
[*.py]
indent_style = space
+max_line_length = 88
[*.{yml,yaml}]
indent_style = space
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
index 7d6b455..5424298 100644
--- a/.github/workflows/main.yml
+++ b/.github/workflows/main.yml
@@ -7,10 +7,13 @@ jobs:
strategy:
matrix:
python:
- - 3.6
+ - 3.7
- 3.9
- - 3.10.0-alpha - 3.10.99
- platform: [ubuntu-latest, macos-latest, windows-latest]
+ - "3.10"
+ platform:
+ - ubuntu-latest
+ - macos-latest
+ - windows-latest
runs-on: ${{ matrix.platform }}
steps:
- uses: actions/checkout@v2
@@ -34,7 +37,7 @@ jobs:
- name: Setup Python
uses: actions/setup-python@v2
with:
- python-version: 3.9
+ python-version: "3.10"
- name: Install tox
run: |
python -m pip install tox
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index c15ab0c..edf6f55 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -1,10 +1,5 @@
repos:
- repo: https://github.com/psf/black
- rev: 20.8b1
+ rev: 22.1.0
hooks:
- id: black
-
-- repo: https://github.com/asottile/blacken-docs
- rev: v1.9.1
- hooks:
- - id: blacken-docs
diff --git a/README.rst b/README.rst
index b964e5a..d5eab1b 100644
--- a/README.rst
+++ b/README.rst
@@ -17,7 +17,7 @@
.. .. image:: https://readthedocs.org/projects/skeleton/badge/?version=latest
.. :target: https://skeleton.readthedocs.io/en/latest/?badge=latest
-.. image:: https://img.shields.io/badge/skeleton-2021-informational
+.. image:: https://img.shields.io/badge/skeleton-2022-informational
:target: https://blog.jaraco.com/skeleton
.. image:: https://tidelift.com/badges/package/pypi/pytest-runner
diff --git a/docs/conf.py b/docs/conf.py
index 2ac23dd..a8bdc15 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -32,6 +32,13 @@ link_files = {
# Be strict about any broken references:
nitpicky = True
+# Include Python intersphinx mapping to prevent failures
+# jaraco/skeleton#51
+extensions += ['sphinx.ext.intersphinx']
+intersphinx_mapping = {
+ 'python': ('https://docs.python.org/3', None),
+}
+
# Custom sidebar templates, maps document names to template names.
html_theme = 'alabaster'
templates_path = ['_templates']
diff --git a/pyproject.toml b/pyproject.toml
index 28bd788..190b355 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,5 +1,5 @@
[build-system]
-requires = ["setuptools>=56", "wheel", "setuptools_scm[toml]>=3.4.1"]
+requires = ["setuptools>=56", "setuptools_scm[toml]>=3.4.1"]
build-backend = "setuptools.build_meta"
[tool.black]
diff --git a/pytest.ini b/pytest.ini
index 31b114f..80e98cc 100644
--- a/pytest.ini
+++ b/pytest.ini
@@ -2,10 +2,16 @@
norecursedirs=dist build .tox .eggs
addopts=--doctest-modules
doctest_optionflags=ALLOW_UNICODE ELLIPSIS
-# workaround for warning pytest-dev/pytest#6178
-junit_family=xunit2
filterwarnings=
# Suppress deprecation warning in flake8
ignore:SelectableGroups dict interface is deprecated::flake8
- # Suppress deprecation warning in pypa/packaging#433
- ignore:The distutils package is deprecated::packaging.tags
+
+ # shopkeep/pytest-black#55
+ ignore:<class 'pytest_black.BlackItem'> is not using a cooperative constructor:pytest.PytestDeprecationWarning
+ ignore:The \(fspath. py.path.local\) argument to BlackItem is deprecated.:pytest.PytestDeprecationWarning
+ ignore:BlackItem is an Item subclass and should not be a collector:pytest.PytestWarning
+
+ # tholo/pytest-flake8#83
+ ignore:<class 'pytest_flake8.Flake8Item'> is not using a cooperative constructor:pytest.PytestDeprecationWarning
+ ignore:The \(fspath. py.path.local\) argument to Flake8Item is deprecated.:pytest.PytestDeprecationWarning
+ ignore:Flake8Item is an Item subclass and should not be a collector:pytest.PytestWarning
diff --git a/setup.cfg b/setup.cfg
index 14bff40..6808bd6 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -17,7 +17,7 @@ classifiers =
packages = find_namespace:
py_modules = ptr
include_package_data = true
-python_requires = >=3.6
+python_requires = >=3.7
install_requires =
# setuptools 27.3 is required at run time
@@ -31,14 +31,14 @@ exclude =
[options.extras_require]
testing =
# upstream
- pytest >= 4.6
+ pytest >= 6
pytest-checkdocs >= 2.4
pytest-flake8
pytest-black >= 0.3.7; \
# workaround for jaraco/skeleton#22
python_implementation != "PyPy"
pytest-cov
- pytest-mypy; \
+ pytest-mypy >= 0.9.1; \
# workaround for jaraco/skeleton#22
python_implementation != "PyPy"
pytest-enabler >= 1.0.1
@@ -49,7 +49,7 @@ testing =
docs =
# upstream
sphinx
- jaraco.packaging >= 8.2
+ jaraco.packaging >= 9
rst.linker >= 1.9
# local
diff --git a/setup.py b/setup.py
deleted file mode 100644
index e58e686..0000000
--- a/setup.py
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/usr/bin/env python
-
-import setuptools
-
-
-compat = dict(
- name='pytest-runner',
- py_modules=['ptr'],
- setup_requires=['setuptools_scm >= 1.15.0'],
- entry_points={'distutils.commands': ['ptr = ptr:PyTest', 'pytest = ptr:PyTest']},
-)
-"""
-Because pytest-runner is frequently installed by
-setup_requires and thus easy_install, and because
-many systems still run with setuptools prior to
-30.4 in which support for declarative config was
-added, supply the basic metadata here. Ref #49.
-"""
-
-if __name__ == "__main__":
- setuptools.setup(**compat)