summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPrzemyslaw Gajda <quermit@gmail.com>2012-04-29 00:56:00 +0200
committerPrzemyslaw Gajda <quermit@gmail.com>2012-04-29 00:56:00 +0200
commitea72ff8485a32e05c48f2b271f2782275fc28931 (patch)
tree7bf4e0b3830ce5e991da16f3ea727c2279fc604c
parentc0557d6f1a423dd6a68336a89c3f2d748d7926d2 (diff)
downloadpymox-ea72ff8485a32e05c48f2b271f2782275fc28931.tar.gz
Applied some changes according to http://getpython3.com/diveintopython3/packaging.html
-rw-r--r--COPYING.txt (renamed from COPYING)0
-rw-r--r--MANIFEST.in2
-rw-r--r--README.txt (renamed from README)0
-rw-r--r--setup.py13
4 files changed, 14 insertions, 1 deletions
diff --git a/COPYING b/COPYING.txt
index d645695..d645695 100644
--- a/COPYING
+++ b/COPYING.txt
diff --git a/MANIFEST.in b/MANIFEST.in
new file mode 100644
index 0000000..b5ad0c1
--- /dev/null
+++ b/MANIFEST.in
@@ -0,0 +1,2 @@
+include COPYING.txt
+include README.txt
diff --git a/README b/README.txt
index 7b65393..7b65393 100644
--- a/README
+++ b/README.txt
diff --git a/setup.py b/setup.py
index feab1dd..4ddd25c 100644
--- a/setup.py
+++ b/setup.py
@@ -20,8 +20,10 @@ from distutils.core import setup
setup(name='mox3',
version='0.6.0',
- py_modules=['mox3.mox', 'mox3.stubout'],
+ packages=['mox3'],
url='https://github.com/quermit/pymox',
+ author='quermit',
+ author_email='quermit@gmail.com',
maintainer='quermit',
maintainer_email='quermit@gmail.com',
license='Apache License, Version 2.0',
@@ -29,4 +31,13 @@ setup(name='mox3',
long_description=('Mox3 is a mock object framework for Python 3 based on '
'the Google mox framework. The library should work '
'well with Python 3.2, 2.7 and 2.6'),
+ classifiers=['Programming Language :: Python',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Operating System :: OS Independent',
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'Topic :: Software Development :: Testing'],
)