summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/ci.yaml8
1 files changed, 4 insertions, 4 deletions
diff --git a/.github/workflows/ci.yaml b/.github/workflows/ci.yaml
index 117ff52..2ef6b20 100644
--- a/.github/workflows/ci.yaml
+++ b/.github/workflows/ci.yaml
@@ -7,7 +7,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: [3.7,3.8,3.9,pypy3]
+ python-version: [3.7,3.8,3.9,pypy-3.9]
steps:
- name: Check out code from GitHub
uses: actions/checkout@v3
@@ -26,7 +26,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: [3.7,3.8,3.9,pypy3]
+ python-version: [3.7,3.8,3.9,pypy-3.9]
steps:
- name: Check out code from GitHub
uses: actions/checkout@v3
@@ -34,7 +34,7 @@ jobs:
run: docker build -t rabbitmq:tls .
- name: Set up Python ${{ matrix.python-version }}
id: python
- uses: actions/setup-python@vv
+ uses: actions/setup-python@v4
with:
python-version: ${{ matrix.python-version }}
- name: Install dependencies
@@ -45,7 +45,7 @@ jobs:
run: |
CELERY_ENABLE_SPEEDUPS=1 python setup.py develop
tox -v -e ${{ matrix.python-version }}-integration-rabbitmq -- -v
- if: ${{ matrix.python-version != 'pypy3'}}
+ if: ${{ matrix.python-version != 'pypy-3.9'}}
#################### Linters and checkers ####################
lint: