summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAsif Saif Uddin <auvipy@gmail.com>2022-12-29 19:34:58 +0600
committerAsif Saif Uddin <auvipy@gmail.com>2022-12-29 19:46:41 +0600
commit41cfe539494410f685e133c1fa180a0595f7825c (patch)
treecc8417b137c0b47a78e06f7f0642765bfc3c8f03
parent15b178bc551b29387978c68ab62e7e4a61798a27 (diff)
downloadpy-amqp-41cfe539494410f685e133c1fa180a0595f7825c.tar.gz
try explicit pypy version
-rw-r--r--.github/workflows/ci.yaml8
1 files changed, 4 insertions, 4 deletions
diff --git a/.github/workflows/ci.yaml b/.github/workflows/ci.yaml
index 117ff52..2ef6b20 100644
--- a/.github/workflows/ci.yaml
+++ b/.github/workflows/ci.yaml
@@ -7,7 +7,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: [3.7,3.8,3.9,pypy3]
+ python-version: [3.7,3.8,3.9,pypy-3.9]
steps:
- name: Check out code from GitHub
uses: actions/checkout@v3
@@ -26,7 +26,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: [3.7,3.8,3.9,pypy3]
+ python-version: [3.7,3.8,3.9,pypy-3.9]
steps:
- name: Check out code from GitHub
uses: actions/checkout@v3
@@ -34,7 +34,7 @@ jobs:
run: docker build -t rabbitmq:tls .
- name: Set up Python ${{ matrix.python-version }}
id: python
- uses: actions/setup-python@vv
+ uses: actions/setup-python@v4
with:
python-version: ${{ matrix.python-version }}
- name: Install dependencies
@@ -45,7 +45,7 @@ jobs:
run: |
CELERY_ENABLE_SPEEDUPS=1 python setup.py develop
tox -v -e ${{ matrix.python-version }}-integration-rabbitmq -- -v
- if: ${{ matrix.python-version != 'pypy3'}}
+ if: ${{ matrix.python-version != 'pypy-3.9'}}
#################### Linters and checkers ####################
lint: