summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-x.ci/travis/run.sh8
1 files changed, 6 insertions, 2 deletions
diff --git a/.ci/travis/run.sh b/.ci/travis/run.sh
index a0cdd1b6..f0ad3737 100755
--- a/.ci/travis/run.sh
+++ b/.ci/travis/run.sh
@@ -5,6 +5,8 @@ set -x
PYVER=`python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))'`
+python -V
+
# setup OSX
if [[ "$(uname -s)" == 'Darwin' ]]; then
if which pyenv > /dev/null; then
@@ -17,8 +19,10 @@ fi
python setup.py build
python setup.py develop
-# run tests (with coverage)
-if [[ $PYVER == '2.7' ]] && [[ "$(uname -s)" != 'Darwin' ]]; then
+# run tests
+if [[ $PYVER == '2.6' ]]; then
+ python -c "import psutil"
+else if [[ $PYVER == '2.7' ]] && [[ "$(uname -s)" != 'Darwin' ]]; then
coverage run psutil/tests/__main__.py
else
python psutil/tests/__main__.py