summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-05-06 21:06:47 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2017-05-06 21:06:47 +0200
commit3b420a88d4ad47fa23021dd85f0e1e621f502bb3 (patch)
tree4951ef50ec2bdf67e91e5e426f308047a9c75650
parent475211e0159bb6ca5f99186b0fe0efedb88bde7f (diff)
downloadpsutil-1053-drop-py26-test-support.tar.gz
#1053 / 2.6: just import psutil, don't run tests1053-drop-py26-test-support
-rwxr-xr-x.ci/travis/run.sh8
1 files changed, 6 insertions, 2 deletions
diff --git a/.ci/travis/run.sh b/.ci/travis/run.sh
index a0cdd1b6..f0ad3737 100755
--- a/.ci/travis/run.sh
+++ b/.ci/travis/run.sh
@@ -5,6 +5,8 @@ set -x
PYVER=`python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))'`
+python -V
+
# setup OSX
if [[ "$(uname -s)" == 'Darwin' ]]; then
if which pyenv > /dev/null; then
@@ -17,8 +19,10 @@ fi
python setup.py build
python setup.py develop
-# run tests (with coverage)
-if [[ $PYVER == '2.7' ]] && [[ "$(uname -s)" != 'Darwin' ]]; then
+# run tests
+if [[ $PYVER == '2.6' ]]; then
+ python -c "import psutil"
+else if [[ $PYVER == '2.7' ]] && [[ "$(uname -s)" != 'Darwin' ]]; then
coverage run psutil/tests/__main__.py
else
python psutil/tests/__main__.py