summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml11
1 files changed, 10 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 1e66aee..1c61464 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,7 +1,16 @@
language: python
python:
+ - "pypy"
- "2.6"
- "2.7"
- "3.2"
- "3.3"
-script: python setup.py test \ No newline at end of file
+install:
+ - if [[ $TRAVIS_PYTHON_VERSION == '2.6' ||
+ $TRAVIS_PYTHON_VERSION == '2.7' ||
+ $TRAVIS_PYTHON_VERSION == 'pypy' ]]; then
+ pip install ./pies2overrides;
+ fi
+script:
+ - pip install pytest
+ - py.test