summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorMarc Abramowitz <marc@marc-abramowitz.com>2014-02-24 08:10:45 -0800
committerMarc Abramowitz <marc@marc-abramowitz.com>2014-02-24 08:23:52 -0800
commit3d1cf9fd685ad476e631d2bca76024bc9447be5d (patch)
tree8799acae247a8731e0b4918bb44e9dd6c487c6eb /.travis.yml
parentcab3ed320873cd9cf64109559df7a528747d8d00 (diff)
downloadpies-3d1cf9fd685ad476e631d2bca76024bc9447be5d.tar.gz
.travis.yml: Run py.test, install pies2overrides for py2
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml11
1 files changed, 10 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 1e66aee..1c61464 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,7 +1,16 @@
language: python
python:
+ - "pypy"
- "2.6"
- "2.7"
- "3.2"
- "3.3"
-script: python setup.py test \ No newline at end of file
+install:
+ - if [[ $TRAVIS_PYTHON_VERSION == '2.6' ||
+ $TRAVIS_PYTHON_VERSION == '2.7' ||
+ $TRAVIS_PYTHON_VERSION == 'pypy' ]]; then
+ pip install ./pies2overrides;
+ fi
+script:
+ - pip install pytest
+ - py.test