summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2014-12-25 01:51:44 -0500
committerTimothy Crosley <timothy.crosley@gmail.com>2014-12-25 01:51:44 -0500
commitb0520f615f1b3f90a5820396789a82e3277854c9 (patch)
treeb53f08d6b6dd819a0ecc726b54298d8fdf3e69fa
parentc6b7447c5d38431406e0f0bc79df1852618d2125 (diff)
parent5862643318f15a4ee74b21386bbe90c8b33cdb23 (diff)
downloadpies-b0520f615f1b3f90a5820396789a82e3277854c9.tar.gz
Merge branch 'release/2.6.3'2.6.3
-rw-r--r--pies/__init__.py2
-rw-r--r--pies/overrides.py4
-rw-r--r--pies2overrides/setup.py4
-rw-r--r--setup.py4
4 files changed, 9 insertions, 5 deletions
diff --git a/pies/__init__.py b/pies/__init__.py
index b1aa082..dbcdf3f 100644
--- a/pies/__init__.py
+++ b/pies/__init__.py
@@ -28,4 +28,4 @@ CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFT
OTHER DEALINGS IN THE SOFTWARE.
"""
-__version__ = "2.6.2"
+__version__ = "2.6.3"
diff --git a/pies/overrides.py b/pies/overrides.py
index 1d64f66..ca3fe39 100644
--- a/pies/overrides.py
+++ b/pies/overrides.py
@@ -98,7 +98,11 @@ else:
integer_types = (int, long)
import sys
+ stdout = sys.stdout
+ stderr = sys.stderr
reload(sys)
+ sys.stdout = stdout
+ sys.stderr = stderr
sys.setdefaultencoding('utf-8')
def _create_not_allowed(name):
diff --git a/pies2overrides/setup.py b/pies2overrides/setup.py
index ad5649d..5f0a67b 100644
--- a/pies2overrides/setup.py
+++ b/pies2overrides/setup.py
@@ -14,12 +14,12 @@ if sys.version_info[0] == 2 and sys.version_info[1] < 7:
install_requires += ['ordereddict', 'argparse']
setup(name='pies2overrides',
- version='2.6.2',
+ version='2.6.3',
description='Defines override classes that should be included with pies only if running on Python2.',
author='Timothy Crosley',
author_email='timothy.crosley@gmail.com',
url='https://github.com/timothycrosley/pies',
- download_url='https://github.com/timothycrosley/pies/blob/master/pies2overrides/dist/pies2overrides-2.6.2.tar.gz?raw=true',
+ download_url='https://github.com/timothycrosley/pies/blob/master/pies2overrides/dist/pies2overrides-2.6.3.tar.gz?raw=true',
license="MIT",
install_requires=install_requires,
requires=install_requires,
diff --git a/setup.py b/setup.py
index fd13d9d..19ce028 100644
--- a/setup.py
+++ b/setup.py
@@ -24,13 +24,13 @@ except (IOError, ImportError, OSError, RuntimeError):
readme = ''
setup(name='pies',
- version='2.6.2',
+ version='2.6.3',
description='The simplest way to write one program that runs on both Python 2 and Python 3.',
long_description=readme,
author='Timothy Crosley',
author_email='timothy.crosley@gmail.com',
url='https://github.com/timothycrosley/pies',
- download_url='https://github.com/timothycrosley/pies/blob/master/dist/pies-2.6.2.tar.gz?raw=true',
+ download_url='https://github.com/timothycrosley/pies/blob/master/dist/pies-2.6.3.tar.gz?raw=true',
license="MIT",
install_requires=install_requires,
requires=install_requires,